Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Can't get into Wifi on my ASUS Notebook U56E?

Hi I have an HP pavilion g6 series with a slow Internet connection I tried WiFi and LAN but always the same problem my broadcom is a corporation BCM4313.

I also tried Fedora the last Version but couldn't get any connection, but on Windows 7 all worked just fine.

share|improve this question

marked as duplicate by jokerdino, James Apr 26 '12 at 14:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Are other machines slow too, or is it just yours? You might want to make sure it is an issue with your specific machine / OS, and not your router, modem, ISP, etc... – John Apr 24 '12 at 0:38
Check out my answer at… Good luck. – Dave Apr 24 '12 at 1:05
thanks Dave it's solved now thanks everyone for the help – Imad BELHAUSS Apr 24 '12 at 16:03
@Dave Could you repost your solution here. And belhauss, could you then mark it as your Accepted Answer? Thanks – Jjed Apr 24 '12 at 18:46

Make sure you are running the right firmware and that the right module is being loaded.. you can use dmesg|grep firmware to see if there are any kernal based firmware error messages. look up the firmware and drivers needed for your device and make sure that they are both correct. most broadcom chips require additonal firmware that cannot be installed by default out of legality

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.