Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded ubuntu from 9.04 to 9.10. well some of the keys of my keyboard don't work properly so i always hit up terminal an use on screen keyboard 'onboard' But when i have upgraded ubuntu and when i launch 'onboard' it shows me following error:

WARNING:Config:Can't load Default loading default layout instead

Then the on screen keyboard gets launched. But when i minimize it, it automatically crashes.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I have 9.10 Karmic and 10.10 Maverick systems at hand and if I start onboard from the terminal I got the same warning on both of them as well: "WARNING:Config:Can't load Default loading default layout instead" on both systems. Here is the screenshot from the Maverick fresh installation:

alt text

What does that warning mean? I'm not sure but I feel that its something related with the keyboard layout. I use "Turkish Q" layout. That warning might try to say that "there's a Default layout for onboard but, for now, not that Default but your default layout will be started". If this is the case, obviously, it makes sense. However, I have no clue what the "main Default" is or what to do in order not to get that warning, but -at least for me- that warning has no ill effect and I didn't even know about such a warning before I read your question. (I don't start onboard from terminal so I haven't seen it.) In my opinion that is not the important part of your problem or maybe its not an issue at all.

Your second and main problem: You say that onboard crashes when you minimize it. On my Maverick system, when I minimize onboard (version 0.94.0), its icon still lies on the bottom panel as usual for most of the programs. Like this (circled in red):

alt text

But on my Karmic system (onboard version 0.92.0) it behaves in a different way: When I minimize onboard , its icon sits the top panel, right side. Like this (circled in red):

alt text

On Karmic, with onboard version 0.92.0, if this is not set to be on top panel, it crashes when onboard is minimized. Most probably, this is a bug. So, on Karmic, I set it to be on top panel. On Maverick, with onboard version 0.94.0, both ways work, as it should be, so its up to taste to choose one or the other behaviour, i.e. minimizing to top or bottom. It may be possible to uninstall 0.92.0 and install 0.94.0 on Karmic but I didn't try it and I don't know if there are dependency problems or not.

So, from where can we set this behaviour? Let's go to the Settings section of onboard. How? Start onboard (version 0.92.0 in this example) and click on the area circled in red:

alt text

Now click on the Settings :

alt text

Tick the option "Show icon in system tray to hide/show onboard":

alt text

Settings interface for onboard 0.94.0 is a little bit different, but the same choise exists as shown belown (remember that on Maverick with v. 0.92.0 that choice was a must as a workaround to prevent crash; here it is optional as an option should be):

alt text

In short, in your situation (Karmic + most probably onboard v. 0.92.0) I advice to tick that box. Then, you don't have to start it from the terminal; you may start it via Alt+F2 or via Applications menu (if you have added onboard to the menu.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.