Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to add a default route on my ppp0 connection, I want the default route points to that connection. I tried to add it in /etc/rc.local but I don't think that is the right place to do so. I would like to know where is the right place to accomplish this.

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What kind of network interface are you talking about? eth, wireless, ... ? –  txwikinger Aug 5 '10 at 19:52
    
ethernet, i need to add this "route add default gw xxx.xxx.xxx.xxx" but when the machine shutdown or restart it loses.. –  fcosp Aug 5 '10 at 19:58

4 Answers 4

The right place should be the file /etc/network/interfaces. You add a line like:

up route add default gw 192.168.0.1 dev eth0

The IP address is the one of your default gateway and the last entry is the device name of your device.

share|improve this answer
    
here is the las think i tried. The problem is that my conexion is ppp0, my eth0 is my LAN, and the eth1 is the ISP conexion... i put in /etc/network/interfaces "up route add default gw xxx.xxx.xxx.xxx dev eth1" also try with "up route add default gw xxx.xxx.xxx.xxx dev ppp0" and didnt work.. in both cases when i run netstat -nr i get this: Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp –  fcosp Aug 5 '10 at 20:59
    
if i run in command line "route add default gw xxx.xxx.xxx.xxx dev ppp0" Works! after run netstat -nr i get Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 xxx.xxx.xxx.xxx 0.0.0.0 UG 0 0 0 ppp0 –  fcosp Aug 5 '10 at 20:59
2  
Are you using Network Manager? It'll overwrite this setting. –  maco Aug 18 '10 at 19:55

If you are using Network Manager, you can add a route via the Configure VPN... menu option under the networking widget. Then on the VPN, click on edit for the VPN you need to add a route to. Then under IPV4 settings, change Method to Automatic VPN. Then click on routes and add your route there (eg network 192.168.1.0 netmask 255.255.255.0 gateway 192.168.1.20) where the gateway is the VPN server you are connecting to.

share|improve this answer

Already long time ago, but none of the above described solutions worked for me. I finally found the solution in the comments in the ip-up file under the /etc/ppp directory in Ubuntu.

I created a script in the /etc/ppp/ip-up.d directory, where I put the route add command in.

The script is picked up automatically after the pptp connection was created. It works like a charm.

share|improve this answer

Your default route for your primary interface? This should be done by default if you're using DHCP. If you have a statically configured interface, you'll need to add a stanza to /etc/network/interfaces. Assuming your interface is eth0 and network is 192.168.1.0/24:

# The primary network interface
auto eth0 

iface eth0 inet static
address 192.168.1.123
netmask 255.255.255.0
gateway 192.168.1.1

(Obviously these numbers would be adjusted for your network.)

Add this to /etc/network/interfaces and that's it. Now if you want a static route that is NOT your default route, that is different.

share|improve this answer
1  
Is there a cli method / file to edit that isn't going to be immediately overwritten by NetworkManager? –  djeikyb Mar 17 '11 at 2:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.