Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are several reports that say that there are serious performance issues using 12.04 and nVidia 7100.

Are there any work-a-round in sight?

share|improve this question
    
try open drivers, binary drivers, and unity 2d. in that order. i have an older nvidia dedicated card on my laptop that took some tweaking, but it works fine now. –  hbdgaf Apr 23 '12 at 13:21
    
Please provide a link to these reports, also test your computer with a live usb install or seperate beta partition and then report a bug in the normal way. –  Martin Owens -doctormo- Apr 23 '12 at 14:07
    
No problem with NVidia Quadro NVS 110M, which has an NVidia GeForce Go 7300 chip, I believe. –  RobinJ Apr 23 '12 at 14:38
    
Right now I compine binary driver and unity 2, but its the media machine (connected to the familys TV) and neighter play channels thru webbrowser, Me-TV or xbmc work well with that configuration. –  Anders Wallenquist Apr 23 '12 at 16:08
    
bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/… bugs.launchpad.net/ubuntu/+source/compiz/+bug/959677 bugs.launchpad.net/ubuntu/+source/linux/+bug/961349 bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/… There are several bug reports, I don't think another one will contribute something new. But reading between the lines, it may be some work-a-rounds. –  Anders Wallenquist Apr 23 '12 at 16:20
show 3 more comments

4 Answers 4

Here's another bug report to add to the list:

https://bugs.launchpad.net/unity/+bug/987469

share|improve this answer
add comment
up vote 1 down vote accepted

This is how I solved the problem (found in a discussion in ubuntuforum.org). I installed the old nvidia-173 driver AND downgraded xserver-xorg. After this XBMC, Unity and other GPU-hungry things started to work again.

1) /etc/apt/preferences.d/10xorg

Package: xorg xserver-xorg*
Pin: release a=oneiric
Pin-Priority: 1050
# So i can find dependencies for the older driver

2) /etc/X11/xorg.conf

# New section
Section "Extensions"
Option "Composite" "Disable"
EndSection

3) install nvidia-173 using synaptic or apt-get

share|improve this answer
1  
Well... step 2 alone "fixes" the issue, but basically makes Unity 3D act like 2D, which kind of defeats the purpose of the fix. –  01es May 2 '12 at 20:26
add comment

Downgrading to 295.33 helped with my GeForce 7100. Everything works well now.

Type Ctl-Alt-F1, then:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current=295.33-0ubuntu1~precise~xup1

I found this solution in this article: Unity 3d no longer works after installing 12.04

share|improve this answer
add comment

my problem was with geforce gt630m with optimus technologies, and intel HD3000

Problem description: battery duration on linux 1 hour // windows 6 hours

After installing bumblebee, battery duration on linux 4.3 hours

instruction here: http://www.leanuxeros.com/linux/como-instalar-bumblebee-3-0-en-ubuntu-y-debian/

maybe you should use google.translator.com

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.