Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just gone through a pretty rough installation on an old laptop and for some reason it wont recognize my touchpad. The synaptics folder is entirely missing...the xinput list shows that I have a pointer (that must be the touchpad), but the synaptiks software won't recognize the touchpad at all. For some reason it doesnt load due to my boot option. Is there a way to find out why or a device manager or something? Notes:

  1. I am currently booting lubuntu with the boot option "acpi=off"; and tired acpi=off noapic nolapic and several combinations of these 3. Plus....acpi.power_nocheck=1 and acpi_osi=linux, apm=off and noapm. The acpi.power_nocheck=1 worked for a few hours that it started to give me error messages of high core temperature.
  2. An attached mouse works just fine.
share|improve this question
    
have you tried any of the other "acpi=" values in the link help.ubuntu.com/community/BootOptions –  fossfreedom Apr 23 '12 at 8:53
    
... also - have you looked into whether there is a bios update available for your laptop? –  fossfreedom Apr 23 '12 at 8:55
    
@fossfreedom yes, I've tried the noapic and nolapic options (and combinations too). No luck at all. Upgrading the BIOS...I'd rather not mess with that. –  Elysium Apr 23 '12 at 8:56
1  
please add to your question the boot options you've tried from the table "Common Kernel Options" - e.g. "acpi.power_nocheck=1 OR acpi_osi=linux " or "apm=off OR noapm " etc etc. Also add details of any power management options you have in your BIOS. What is your BIOS version - this might be useful to check if a later BIOS update has some fixes. Some details of your laptop would be useful - make - model. –  fossfreedom Apr 23 '12 at 9:02
    
@fossfreedom ok, just edited the main post...by the way, I've never tried acpi.power_nocheck=1 or acpi_osi=linux. –  Elysium Apr 23 '12 at 9:15
show 1 more comment

1 Answer

up vote 1 down vote accepted

general tips

For problems such as this, it is worth looking at the common boot options you can use to boot Ubuntu.

acpi=off turns off all power management features and/does interfere with valuable functionality such as track-pad as well as the expected power-management of your battery and fans etc.

Most often, problems such as this can be traced back to a BIOS that is old, buggy and needs updating to the latest available.

Sometimes, even with the latest BIOS, Ubuntu will need some help.

A valuable resource is the Community Boot options wiki.

For example, try acpi.power_nocheck=1 OR acpi_osi=linux etc.

share|improve this answer
    
sorry to be a pain, but I am back to the same old problem. The acpi_osi=linux worked for a fews hours...and started to give me the error message of high temperature and the laptop shut down. I am back to the acpi=off mode, is there any other options that I could add to make the touchpad work? –  Elysium Apr 23 '12 at 22:10
    
one of my comments above I asked for more information. Please can you add this to your question ... Thanks. –  fossfreedom Apr 23 '12 at 22:42
    
ok, just edited. Thanks. –  Elysium Apr 24 '12 at 8:30
    
"Also add details of any power management options you have in your BIOS. What is your BIOS version - this might be useful to check if a later BIOS update has some fixes. Some details of your laptop would be useful - make - model. " –  fossfreedom Apr 24 '12 at 8:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.