Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been playing with ubuntu for just a few days and so far i really like it. but i am having a few problems more specifically my screen resolution. I'm running

11.04 (natty) kernel linux 2.6.38-14-generic GNOME 2.32.1

on a Dell dimension 2400 with my on bord graphic card

Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01).

I try changing it using the xrandr command but all i get is

xrandr: Failed to get size of gamma for output default

my monitor is unknown and the resolution is 1280 X 1024 with a refresh rate of 0Hz rotation normal and while I'm not sure what it should be I know that everything is way to small for me to see without blowing it up a few times. and I'm not really sure what else i can do. any help would be welcome.

share|improve this question
add comment

2 Answers

Did you try to change the resolution using Display-Settings?

( System-settings ---> Display )

What happens there?


Here are some suggestions:

  • Make sure you have installed all available updates.
  • If you can, install the latest version of Ubuntu, which is Ubuntu-11.10 or just wait a few more days and install the 12.04 LTS (Long Term Support) release. These releases are based on more recent versions of the Linux kernel which includes all hardware drivers. Using a more recent Linux-kernel might solve your problem.
share|improve this answer
    
i don't seem to have that path. the path i have is (system - preferences - monitors) and i can't change anything in any of the drop tabs –  Anthony Barton Apr 23 '12 at 4:32
    
That path is in accordance with the Unity desktop in Ubuntu-11.10 and 12.04 which are based on GNOME-3, and is identical to the path you said which is for GNOME-2. Unfortunately I don't know why you are unable to change the screen resolution in the Display-settings! I will return if I figure out anything. I've edited my answer with some suggestions. That's all I can say for now. –  Seyed Mohammad Apr 23 '12 at 5:43
    
thank you for your help updating it to the new soft ware did fix the problem. –  Anthony Barton Apr 24 '12 at 2:36
add comment

OK guys, after trying and trying with KMS (kernel modesetting), Xorg.conf all kinds of tutorials on google and everywhere... I have THEE most stupid and easy fix that I found today :P I have an old Dell Dimension with an Acer x173w monitor (2cd machine). It had a resolution of 1024x786 which was horrendous. It is supposed to have 1440x900. On the front of the Acer there are menu options. Pan through them til you see "re-set" apply the re-set. It will "adjust itself". Now go back onto your machine, go to settings>display.... and voila!!! You will now see many different resolutions to choose from. Choose the one you want, it will ask you if you wish to keep, if you like, select "yes keep this setting" BAM! done!!! \o/ Hope this solves many headaches. Works for Mint/Ubuntu... and what Im running on the Dell is a new distro called SalineOS. Im running Mint 14 Cinnamon on this Toshiba lappy :P

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.