Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

it used to be that tapping two fingers on the touchpad send a middle mouse click. Now it does a right click and three fingers now are the middle click. I really can't understand the change and think it is a bug or badly copied from Apple or something. The reasoning escapes me totally. I use middle click to open links in a new tab in the browser all day and I rarely use right click (and I have a right mouse button below the touchpad, doh) Tapping three fingers on my tiny EeePC touchpad is next to impossible so I want the old behavior. I found:

synclient TapButtons2=2
synclient TapButtons3=3

but that did not work on 10.10

Does anyone know how to restore sane behavior?

share|improve this question
    
Should be TapButton2=2, etc., without the 's'. –  Chan-Ho Suh May 30 '12 at 5:56
add comment

12 Answers

You may also be interested in installing the gpointing-device-settings Install gpointing-device-settings package, which will provide more configuration options for your touchpad. BTW, in Ubuntu 10.04LTS+ this replaces gsynaptics.

Once installed you find it under System -> Preferences -> Pointing Devices.

share|improve this answer
add comment

The default settings that seem to be enabled with "tap to click" (on my laptop anyway) also provides the following functionality:

  • Middle Click (tap at top right of scroll area)
  • Right Click (tap at bottom right of scroll area)
share|improve this answer
1  
That's awesome. And it's working by default I never knew about it. Thank you. Great answer! –  Itay Grudev Aug 21 '12 at 14:06
    
Works great, really hard one to guess. –  Louis-Philippe Huberdeau Sep 10 '12 at 18:12
    
This is not working if you enable "Two-finder scrolling". Two bad, because I like it more then "Edge scrolling". –  Radu Maris Mar 7 '13 at 19:55
add comment

The following solution has been tested on Ubuntu 12.04 and 12.10. It works perfectly.

  1. Create a file /etc/X11/xorg.conf.d/touchpad.conf with the following content:

    Section "InputClass"
            Identifier      "Touchpad"                      # required
            MatchIsTouchpad "on"                           # required
            Driver          "synaptics"                     # required
            Option          "MinSpeed"              "0.5"
            Option          "MaxSpeed"              "1.0"
            Option          "AccelFactor"           "0.075"
            Option          "TapButton1"            "1"
            Option          "TapButton2"            "2"     # multitouch
            Option          "TapButton3"            "3"     # multitouch
            Option          "VertTwoFingerScroll"   "1"     # multitouch
            Option          "HorizTwoFingerScroll"  "1"     # multitouch
            Option          "VertEdgeScroll"        "1"
            Option          "CoastingSpeed"         "8"
            Option          "CornerCoasting"        "1"
            Option          "CircularScrolling"     "1"
            Option          "CircScrollTrigger"     "7"
            Option          "EdgeMotionUseAlways"   "1"
            Option          "LBCornerButton"        "8"     # browser "back" btn
            Option          "RBCornerButton"        "9"     # browser "forward" btn
    EndSection
    
  2. Run dconf-editor from your user (don't sudo). Go to org.gnome.settings-daemon.plugins.mouse, uncheck active. (It is a known issue that Gnome's Settings Daemon may override your xorg.conf settings).

  3. Log out and log in. Things should be working fine now.

share|improve this answer
add comment

xinput gave:

unable to find device SynPS/2 Synaptics TouchPad

so I did

synclient TapButton3=3 TapButton2=2

from a tip from http://ubuntuforums.org/showthread.php?t=1251372

I put this in my ~/.bashrc and things seem to work

share|improve this answer
add comment

To fix the middle click you can use the following command:

xinput set-int-prop NN 266 8 2 3 0 0 1 2 3

Where NN is the id of the mousepad device, you can see it with the command xinput list. 266 is the id of the property "Synaptics Tap Action" you can see it with xinput list-props NN

You have to run this command every time you boot/login/wake.

To make it permanent you can put this command to the end of your .profile file in your home folder. (You can also try to put it in /etc/init.d/rc.local, but in my case it didn't work.)

share|improve this answer
add comment

To preserve your synaptics configuration after resume, I followed this steps from wiki.archlinux.org:

Gnome settings daemon may override existing settings (for example ones set in xorg.conf.d) for which there is no equivalent in any of the graphical configuration utilities. It is possible to stop gnome from touching mouse settings at all:

1. Run dconf-editor
2. Edit /org/gnome/settings-daemon/plugins/mouse/
3. Uncheck the active setting 

It will now respect your system's existing synaptics configuration.

It worked on Ubuntu 11.10 AND now I have:

  • Two-finger scrolling.
  • Middle Click with two fingers tap.
  • Right Click (tap at bottom right of scroll area).
share|improve this answer
add comment

Try running this as a script

xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3  # pad corners rt rb lt lb tap fingers 1 2 3 (can't simulate more then 2 tap fingers AFAIK) - values: 0=disable 1=left 2=middle 3=right etc. (in FF 8=back 9=forward)
share|improve this answer
    
unable to find device SynPS/2 Synaptics TouchPad –  Thomas A. Nov 11 '10 at 0:49
    
xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3 works! –  Thomas A. Nov 14 '10 at 23:40
add comment

OK,

I now have to run

xinput set-prop "ETPS/2 Elantech Touchpad" "Synaptics Tap Action" 8, 9, 0, 0, 1, 2, 3

and

gconftool-2 --set --type=bool /apps/gnome-power-manager/lock/suspend false 

to restore things to something I can tolerate, BUT I have to run those commands after each resume. Which script is run after each resume to automate that?

share|improve this answer
    
/etc/pm/sleep.d/99-test.sh works for me –  Thomas A. Nov 22 '10 at 7:01
    
hmmm, it works for resume with out password but not for making double tap work –  Thomas A. Nov 22 '10 at 8:19
1  
why is thid so hard? –  Thomas A. Nov 22 '10 at 8:20
add comment

Add this to /etc/X11/xorg.conf:

Section "InputClass"
Identifier "middle button emulation class"
MatchIsPointer "on"
Option "Emulate3Buttons" "on"
EndSection

WARNING: try with caution. When added to ~50-synaptics.conf in 11.10, may cause boot hang after login screen.

share|improve this answer
add comment

Solution #1

I just discovered that if you keep two fingers pressed on touchpad and press the left click "button" of the touchpad it emulates the middle mouse button (so you need 3 fingers in total)

Solution #2

If you still want to click both buttons and produce a middle button emulation, execute:

synclient EmulateMidButtonTime=100

EmulateMidButtonTime allows you to change the time required to produce a middle button (allowed time period to click both buttons). 100 means 100 milliseconds (ms).

You may set it to even higher values, such as synclient EmulateMidButtonTime=500 for 500ms, which is enough time to click both buttons

share|improve this answer
add comment

I did exactly what Nikita Volkov said (creating xorg.conf.d folder and touchpad.conf file), but my file looks like this:

Section "InputClass"
    Identifier      "Touchpad"                      # required
    MatchIsTouchpad "on"                            # required
    Driver          "synaptics"                     # required
    Option          "MinSpeed"              "0.5"
    Option          "MaxSpeed"              "1.0"
    Option          "AccelFactor"           "0.075"
    Option          "TapButton1"            "1"
    Option          "TapButton2"            "2"     # multitouch
    Option          "TapButton3"            "3"     # multitouch
    Option          "VertTwoFingerScroll"   "1"     # multitouch
    Option          "HorizTwoFingerScroll"  "0"     # multitouch
    Option          "MaxTapTime"            "70"
    Option          "FastTaps"              "1"
EndSection

and now it's perfect!

share|improve this answer
add comment
synclient TapButton2=3 TapButton3=2

key named according to number of fingers, value indicates mouse button number.

share|improve this answer
3  
Sorry, my original comment wasn't very useful. I confused this with a totally separate post. I apologize. Let me start again: If this method (which does not contain a typo, though the original question here does) is different from the method that the original question said does not work, you should edit this answer to explain how it is different. That is probably why this answer was downvoted. You should also edit this answer to explain what needs to be done in complete sentences, and to make clear what parts of your answer are commands and what parts are the explanation. –  Eliah Kagan May 30 '12 at 7:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.