Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a second monitor so I can have dual screens on my desktop computer. Upgrading to 12.04, using BIOS to set my main graphic processor to "onboard", and changing the nvidia x server settings to the "seperate x screen" configuration, I was able to succeed in getting Dual Monitors, which I am very proud to have accomplished. The sacrifice seems to have been that I lost some of the cool effects of the sliders, [alt]+[tab] changer looks like windows 95, the workspace changer doesn't work, I cannot access my display preferences outside of the Nvidia X Server. When I go to display preferences, I get this pop-up "Could not get screen information" "RANDR extension is not present". I could be wrong, but it looks like the effects of Unity were disabled when Nvidia took over the Display preferences. How do I return my computer to the fresh look I had when I first installed precise Pangolin and have dual Monitors at the same time?

More info:

My main monitor is plugged into my Graphics card expansion listed as NVIDIA Corporation GT218 [GeForce 210], my secondary Monitor is plugged into the VGA port in my Motherboard's I/O Panel which is listed as NVIDIA Corporation C61 [GeForce 7025 / nForce 630a]. I have the accelerated graphics driver "Nvidia accelerated graphics driver (post release updates)(current version updates)" installed.

  • Here's my Hardware specs from typing sudo lshw. http://pastebin.ubuntu.com/944869/.

  • Also I ran LIBGL_DEBUG=verbose glxinfo and got this: http://pastebin.ubuntu.com/944871/

  • This is what I got when I entered this command: lspci -nn | grep VGA

    00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2) 02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2)

  • My Motherboard Model is ASRock N68-VS3 UCC

share|improve this question
    
Can you add to your question if you've installed the nvidia drivers yet? –  Jorge Castro Apr 24 '12 at 16:57
    
(Add this to your question so it's bumped!) –  Jorge Castro Apr 24 '12 at 22:29
    
Please post your /etc/X11/xorg.conf in pastebin. –  nem75 Apr 25 '12 at 16:28
    
@nem75: here you go: pastebin.ubuntu.com/946416 –  Stanton.Sculpture Apr 25 '12 at 22:01
    
Looks ok as far as "separate X screen" configurations go. Is there any special reason why you did not choose the much more comfortable "Twinview" configuration in nvidia-settings? Maybe it will fix your other problems, too. –  nem75 Apr 26 '12 at 7:45
show 4 more comments

3 Answers

up vote 2 down vote accepted

you must attach a second monitor to the GFX second video port

EDIT: you cannot have the second monitor attached to the inbuilt motherboard video output, attach the second monitor to the second video output present on the graphics card, like misery said you can only use one video card at a time, either the dedicated video card or GFX card as i call it, or the internal, how old is your PC, by the looks of your video card specs i think pretty old as no graphics card since past 3-4 years had made available VGA on its card, they either have a DVI or HDMI and that too two of those!!!

share|improve this answer
    
I'm not sure what a GFX second video port is. –  Stanton.Sculpture Apr 24 '12 at 17:41
    
you cannot have the second monitor attached to the inbuilt motherboard video output, attach the second monitor to the second video output present on the graphics card, like misery said you can only use one video card at a time, either the dedicated video card or GFX card as i call it, or the internal, how old is your PC, by the looks of your video card specs i think pretty old as no graphics card since past 3-4 years had made available VGA on its card, they either have a DVI or HDMI and that too two of those!!! –  sarveshlad Apr 25 '12 at 16:22
    
Well I don't know what to tell you, I have both monitors running just fine. One out of my motherboard 00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2) and one out of my graphics card 02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) –  Stanton.Sculpture Apr 25 '12 at 22:12
    
I had to reboot, go into BIOS > Advanced > Chipset > and change "Share memory" from "Auto" to "256MB", then in Ubuntu I went to the Nvidia X server, I had to enable the second monitor. I guess I lucked out with the VGA ports because I got the monitors from a thrift store, both for $15.00USD! They're not the best but they work great outside a few scratches on the one. Good info for anyone building computers on a budget. –  Stanton.Sculpture Apr 25 '12 at 22:29
    
you are lucky man!!! u might need help setting up x server or something and thats advance level i doubt i can be of further assist.... maybe you should checkout ubuntu forums –  sarveshlad Apr 26 '12 at 2:40
show 1 more comment

In general Ubuntu supports multiple monitors very well. Thanks to Gnome even better than Windows. Please read this post. I have described there how to make work (if possible) two VGA cards. Anyway I have tested 10.04 with two nVidia cards and three monitors using Xinerama and it worked absolutely great.

share|improve this answer
    
I only have one Nvidia Card with a VGA port, and the other VGA port is in the Motherboard. See my edited question for hardware specs. –  Stanton.Sculpture Apr 24 '12 at 17:48
    
Are You sure that Your mainboard supports using two graphic cards? usually when You have integrated card it is switched off after pluging another card into PCI or similar slot. Did You chceck Your MB's manual? –  Misery Apr 24 '12 at 17:56
    
Yes. The Manual Has detailed instructions on getting it to work. Following the instructions I can get the other monitor2 working with the onboard port or Monitor1 working with the PCIE port by switching them in BIOS, but still not both. –  Stanton.Sculpture Apr 24 '12 at 20:14
    
Thanks to you I got them both working, I think you officially solved my problem by sending me in the right direction. Thank you. No I have lost a lot of the cool affacts of ubuntu's unity interface. Everything looks like Windows 95, non of the cool affects are working, unfortunately. Its like someone else's setting were loaded onto my computer. I'm getting sounds that I wasn't getting before. Its like everything is running in Ubuntu 2D. or something. Its weird. Could you point me in the right direction again to resolve this? –  Stanton.Sculpture Apr 25 '12 at 0:38
    
There are two things to use 3D effects. One is Your cards performance. If it is not enough, You're not able to use good looking interface. The second is that I'm not convinced if Graphical User Interfaces support multiple monitors. I have tested 3 monitors with 2x GT 300 nVidia cards and Xinerama, and unfortunately I did not succeed in enabling visual effects. So I will not be able to help You this time. –  Misery Apr 25 '12 at 8:15
show 1 more comment

Ok so a few things that I realized I was doing backwards. One was that it was a lot easier to keep the both monitors plugged into the same graphics card. I went in circles trying to get it to work outside out of the motherboard, so I bit the bullet and got a DVI to VGA adaptor, plugged everything in right and got immediate results. I went back into BIOS and turned everything back to default settings. Rebooted and immediately went to the nvidia x server and switched to Twin View. Everything went back to normal. Blender worked, workspace switcher was still a little wonky, so I said "screw it" I know what I did wrong, backed up everything, download the new 12.04 installation DVD, and started from scratch. When it was all installed and most of my files returned to their homes, I knew just what to do and I told NVidia to put everything in Twinview, and its been smooth sailing since. I was a fool, but now I have learned my lesson. Thanks to everyone who helped me out! If anyone has anymore questions about what I did wrong and right, let me know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.