Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I decided to dual boot my Mac with Ubuntu 12.04 beta2. Not sure what I changed, but now I can't boot into Ubuntu, a live cd, or OS X. When I try to boot Ubuntu in recovery mode (as for some reasion I can access the grub menu), the last two lines say:

[    1.160316] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found

[    1.160381] EDD information not available.

Am I able to recover my computer?

share|improve this question
    
Recently had the same problem. Gnome-shell crashed on me, making the UI unusuable, so I did a hard reboot, and got the same error... –  Cerin May 20 '12 at 22:40
    
Happened to me on Ubuntu 12.04 stable, not beta. Tried nolapic, acpi=off and edd=on in grub (and combinations of those options, as suggested on ubuntu forums). I've managed to get to mounting root filesystem failed. It's a very strange issue. –  Krzysztof Hasiński May 30 '12 at 7:59
add comment

1 Answer

Reset your Macbook PMU. At least on my model this can be done by, having it turned off, pressing: Cmd + Alt + Ctrl + Shift while pressing the Power button.

I've just had this issue, and it got fixed by doing this

share|improve this answer
    
Holy crap. This actually worked. Pressing those buttons has no immediate effect (the laptop doesn't power on or anything), but afterwards when I pressed only the powerbutton, it booted up correctly. Thanks. –  Cerin Aug 15 '12 at 1:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.