Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install a driver for the Epson SX440. I've downloaded the .deb from: http://openprinting.org/printer/Epson/Epson-SX440_Series but it needs lsb installed. I'm on 10.04, and I go to install lsb 4.0. But that needs libqt4-gui installed. I have the rest of libqt4 at 4.7.0, but libqt4-gui apparently changed its name to libqtgui4 at that version. Since lsb can't find libqt4-gui, it refuses to install, and so I can't install the printer.

What would be the best thing to do here - should I downgrade libqt4 to 4.6.3 (how do I do that?), or is there some way to tell lsb that it can actually find libqt4-gui under the new name of libqtgui4?

Thanks.

ls /etc/apt/sources.list.d | sed '/\.save/ d'
alex-p-notesalexp-lucid.list
and471-kazam-daily-builds-lucid.list
arx-release-lucid.list
cburgmer-ppa-lucid.list
cheleb-blender-svn-lucid.list
dlynch3-ppa-lucid.list
ferramroberto-linuxfreedomlucid-lucid.list
freetuxtv-freetuxtv-lucid.list
google-talkplugin.list
jonoomph-openshot-edge-lucid.list
kubuntu-ppa-backports-lucid.list
kubuntu-ppa-beta-lucid.list
kubuntu-ppa-ppa-lucid.list
matthaeus123-mrw-gimp-svn-lucid.list
me-davidsansome-clementine-lucid.list
medibuntu.list
mozillateam-firefox-stable-lucid.list
neurodebian.sources.list
norsetto-ppa-lucid.list
openclonkdevteam-release-lucid.list
openoffice-pkgs-ppa-lucid.list
opera.list
pyexiv2-developers-ppa-lucid.list
rkward-devel-rkward-stable-lucid.list
shnatsel-gimp-paint-studio-lucid.list
spideroak.com.sources.list
sunab-kdenlive-release-lucid.list
ubuntu-mozilla-daily-ppa-lucid.list
ubuntu-x-swat-x-updates-lucid.list
uqvislab.list
wfg-0ad-lucid.list

apt-cache policy libqt4-gui libqtgui4
libqt4-gui:
Installed: (none)
Candidate: 4:4.6.3-0ubuntu1
Version table:
 4:4.6.3-0ubuntu1 0
    500 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/ lucid/main Packages
 4:4.6.2-0ubuntu5.3 0
    500 http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
    500 http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
 4:4.6.2-0ubuntu5 0
    500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages
libqtgui4:
Installed: 4:4.7.0-0ubuntu2~lucid1~ppa1
Candidate: 4:4.7.0-0ubuntu2~lucid1~ppa1
Version table:
*** 4:4.7.0-0ubuntu2~lucid1~ppa1 0
    100 /var/lib/dpkg/status
 4:4.6.3-0ubuntu1 0
    500 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/ lucid/main Packages
 4:4.6.2-0ubuntu5.3 0
    500 http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
    500 http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
 4:4.6.2-0ubuntu5 0
    500 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Packages
share|improve this question

1 Answer 1

libqt4-gui is still available in Ubuntu 10.04 LTS. It's a "transitional package", which means it doesn't provide any files, and depends on the newly named packages. It exists primarily to ensure the newly named packages get installed when upgrading. But you should still be able to install it.

sudo apt-get update
sudp apt-get install libqt4-gui

If that doesn't work, please comment to indicate what happened.

share|improve this answer
    
Yes, I'd tried that, but I get: Depends: libqtgui4 (=4:4.6.3-0ubuntu1) but 4:4.7.0-0ubuntu2~lucid1~ppa1 is to be installed. The name was changed from 4.7.0, and the rest of libqt4 is at 4.7.0 on this machine. That was why I was wondering if I need to downgrade libqt4. –  donnek Apr 23 '12 at 8:12
    
@donnek Are you intentionally using a PPA to provide QT? –  Eliah Kagan Apr 25 '12 at 0:30
    
Hi Eliah - Indeed, it looks like it has come in from a PPA, but I don't know which one. Using the script at github.com/fab1an/unix-admin-tools/blob/master/dpkg-origins just says "not found in any repository", so I don't know which one to purge. :-( –  donnek Apr 27 '12 at 21:37
    
@donnek Let's see what PPA's you have configured. Please post the output of ls /etc/apt/sources.list.d. Please also post the output of apt-cache policy libqt4-gui libqtgui4. You can edit your question and add this to it. –  Eliah Kagan Apr 28 '12 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.