Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i use ubuntu 11.04 i have problem with create a hotspot. Now im upgrade system to ubuntu 11.10 and i can not create it. When i try create hotspot, network manager in loop ask me for key, but i promt it...

Any idea?

syslog info:

 wpa_supplicant[1099]: Authentication with 00:00:00:00:00:00 timed out.
 wpa_supplicant[1099]: Trying to associate with SSID 'hotspot'
 kernel: [  105.799013] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
 kernel: [  105.799025] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
 wpa_supplicant[1099]: nl80211: Failed to set interface into IBSS mode
 wpa_supplicant[1099]: Association request to the driver failed
 kernel: [  105.801088] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
 kernel: [  105.801765] ADDRCONF(NETDEV_UP): wlan0: link is not ready
 hotspot wpa_supplicant[1099]: Authentication with 00:00:00:00:00:00 timed out.
 hotspot wpa_supplicant[1099]: Trying to associate with SSID 'hotspot'
 hotspot kernel: [  115.859235] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
 hotspot kernel: [  115.859248] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
 hotspot kernel: [  115.859770] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
 hotspot wpa_supplicant[1099]: nl80211: Failed to set interface into IBSS mode
 hotspot wpa_supplicant[1099]: Association request to the driver failed
 hotspot kernel: [  115.861261] ADDRCONF(NETDEV_UP): wlan0: link is not ready
 hotspot wpa_supplicant[1099]: Authentication with 00:00:00:00:00:00 timed out.
 hotspot wpa_supplicant[1099]: Trying to associate with SSID 'hotspot'
 hotspot wpa_supplicant[1099]: nl80211: Failed to set interface into IBSS mode
 hotspot wpa_supplicant[1099]: Association request to the driver failed
 hotspot kernel: [  125.929227] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
 hotspot kernel: [  125.929234] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
 hotspot kernel: [  125.929740] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
 hotspot kernel: [  125.930379] ADDRCONF(NETDEV_UP): wlan0: link is not ready
 hotspot NetworkManager[949]: <warn> Activation (wlan0/wireless): association took too long.
 hotspot NetworkManager[949]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
 hotspot NetworkManager[949]: <warn> Activation (wlan0/wireless): asking for new secrets
 hotspot NetworkManager[949]: <info> (wlan0): supplicant interface state: associating -> disconnected
 hotspot NetworkManager[949]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
 hotspot NetworkManager[949]: <warn> No agents were available for this request.
 hotspot NetworkManager[949]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
 hotspot NetworkManager[949]: <warn> Activation (wlan0) failed for access point (hotspot)
 hotspot NetworkManager[949]: <info> Marking connection 'hotspot' invalid.
 hotspot NetworkManager[949]: <warn> Activation (wlan0) failed.
 hotspot NetworkManager[949]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
 hotspot NetworkManager[949]: <info> (wlan0): deactivating device (reason 'none') [0]
share|improve this question

1 Answer 1

up vote 0 down vote accepted

The solution:

To fix this, I added the following three lines to the bottom of /etc/modprobe.d/blacklist.conf

blacklist bcma
blacklist brcmsmac
blacklist brcmutil

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863799/comments/3

Thanks for help...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.