Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running ubuntu 10.10 on a Lenovo ideapad z560. The speakers run fine but the headphones are not recognized when i plug them in. Audio comes out of the speakers only. I tried all alsa and pulseaudio settings but to no avail. I came to know that this is a known bug and many people are having this problem. I was wondering whether shifting to OSS4 would help. I need some advice because once i make the switch i would need to reconfigure a large number of audio apps. Thanks in advance

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Have you tried to explicitly set the sound card's model in the alsa-base.conf file?

share|improve this answer
    
Iam trying out the linuxant drivers. hope this works. –  tinhed Nov 11 '10 at 6:14
1  
The hdaintelsoundhowto solved my problem. Thanks a lot for the fix. –  tinhed Nov 12 '10 at 12:57
add comment

I would advise that you leave your sound servers alone, maybe you should try if a USB based headphone will help work around the problem until the bug is fixed, also make sure that it is really not a hardware issue, I had an old Dell Inspiron that had a similar problem and it turned out that the problem was hardware failure, Windows that came on it with the proper drivers had the same problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.