Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am planning on doing a fresh install of Ubuntu and want to know what is the correct way to install ATI Catalyst Video Driver?


There are multiple valid answers for this question spanning over several versions of Ubuntu. For your convenience an index of each below:

share|improve this question
    
Care to update this for 14.10? Much obliged! –  Torben Gundtofte-Bruun Oct 31 at 19:00

6 Answers 6

up vote 16 down vote accepted

14.04 - Installing the driver from the AMD website :-

First, make sure your Ubuntu OS is up-to-date. To check this, click the power icon in the top right corner. From the menu select 'About this computer'. Now check if there is a button 'System is up-to-date'(or something similar). If not, there will be a 'Install updates' button(It might appear after a few seconds after the 'Checking updates' button) which can be used to update as shown below:-


(First you might see this) enter image description here

(Then this) enter image description here

(After pressing 'Install Updates' you will see this) enter image description here


One may also resort to using the terminal command as shown below to update:-

sudo apt-get update && sudo apt-get upgrade
  • Then get to the AMD website and the driver can be found and downloaded easily. If you are unsure which driver to install then you might install the '(so called)Driver detecting software' in your Windows OS and see the driver that you ought to install.

  • Check the release notes and installer notes of whichever driver you are going to install without fail. See if your OS meets all the system requirements mentioned in the release notes.

  • Then follow the steps in the installer notes to successfully install your driver.

NOTE:-

1: If you installed the wrong driver(or made some other mistake with installing the driver), unity might crash or you may get "The system is running in low graphics mode" problem(or some other issue). Whatever the problem is, you have to first delete the driver you installed. For this, start a tty session by pressing CTRL+ALT+F1. Then use this command :

sudo aticonfig --uninstall

This should delete your driver. If not refer this . Now use the command:

sudo shutdown -r now

to reboot your system. This should help you to get back to unity without problems. Now you can again get to the AMD site, get a supported driver and install.

If this didn't solve your problem referring to these questions might be useful:-

2: Also if you don't know if your OS satisfies the system requirements of the driver mentioned in its release notes, then the following commands might help:

  1. uname -a :- will let you know about your Kernel
  2. Xorg -version :- will let you know about your Xorg
  3. ldd --version :- will let you know your glibc

Also it is not necessary that your OS needs to specified in the release notes. Just see if you meet the system requirements and if your graphic card is mentioned in the release notes.

3: Make sure you update your OS before installing your graphics driver as stated above. Because your OS might support your driver before updating and after your OS update it might not!!

4: Also don't be startled if your driver installer appears like this(without any text) :-

enter image description here

In this case see the installer notes and with the help of the screen shots provided there install your driver.

P.S:-

In my humble opinion, the default open source drivers serve all the normal needs of computing. So install the proprietary driver only if you really need it(like if you are a 'techy' gamer or something) . Also, if you are trying to install your proprietary driver just to get your maximum screen resolution then you might refer to this answer.

share|improve this answer
    
An extremely complete answer! –  Charles Green Jun 3 at 18:52
    
You said "If you are unsure which driver to install", but I don't seem to have much choice in drivers. When I click "Linux (32-bit & 64-bit)", the only driver that is offered is the same proprietary driver that is offered through the "Additional Drivers" dialogue and those don't work properly –  Peter Raeves Jun 8 at 17:23
    
@PeterRaeves As I commented in your actual question here be sure to try both the stable and the beta proprietary drivers and also the open source drivers and if they don't seem to work then please make sure to file a bug report regarding this. –  Venki Jun 9 at 11:02
    
"make sure your os is up-to-date" lol, not really, the driver provided by amd.com (called fglrx) requires an older version of both xorg and the kernel –  Nick Bailuc Aug 10 at 3:30
1  
Yep it sure is a problem with amd, their beta unreleased driver is already outdated –  Nick Bailuc Aug 10 at 16:23
up vote 101 down vote
+100

The following instructions explain how to install the latest ATI Catalyst video driver of Ubuntu 12.04 LTS (Precise Pangolin).

Note

AMD has released the Catalyst 12.8 driver for Linux systems in August bringing some improvements and bug fixes. This driver is based on the fglrx 8.982 release, and it improves support for Ubuntu 12.04 LTS.


To keep up to date with the latest driver information always refer to AMDs official website as updates are published fairly regularly.

Installing the AMD/ATI Catalyst drivers for 12.04 LTS

Tested: v12.4, v12.6, v12.8


Important Information and Preparation

Only use these instructions if you have opted NOT to use the official Ubuntu binaries.

  • If you wish to use the official Ubuntu binaries or want to install the latest ATI Catalyst video driver for previous versions of Ubuntu, navigate to the answer of this question and follow the instructions.

Before deciding, check if Ubuntu supports your video card here.

  • If you are currently using the official Ubuntu binaries and want to install the latest ATI Catalyst video driver there is a prerequisite to purge some files. Before proceeding with these instructions. You can Skip the step to purge if you have a fresh install of Ubuntu 12.04.

Removing (purging) existing drivers

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Install these dependencies

You need to install some dependencies to your system, do this by running these in Terminal:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

For 64-bit Only

sudo apt-get install ia32-libs-multiarch i386 lib32gcc1 libc6-i386

Installing the lastest ATI/AMD driver

Download the appropriate driver for your machine here from the AMD/ATI Website and then enter the following into the terminal (remember to navigate to where you extracted the driver to beforehand and make sure no other .run files exist in that folder):

sudo sh *.run --buildpkg Ubuntu/precise

If it is required, a package manager window will open and install some dependencies and after a while create the following four .deb packages:

fglrx_8.961-0ubuntu1_amd64.deb
fglrx-amdcccle_8.961-0ubuntu1_amd64.deb
fglrx-dev_8.961-0ubuntu1_amd64.deb

Note: It will also create a file called fglrx-installer_8.961-0ubuntu1_amd64.changes. If you wish you can read this file to know the changes that have been affected through AMD/ATI Catalyst and related information.

To install the created .deb files, type:

sudo dpkg -i *.deb

Note: In case any of the packages are broken, open Synaptic Package Manager and go to Edit -> Fix Broken Packages. In case you are new to Ubuntu, broken here means that some dependent packages are not yet installed. Once you sort out the issue as indicated above through the Synaptic Package Manager, the problem of broken packages should be resolved.

Continuing with the installation, type:

sudo aticonfig --initial

Before rebooting your computer: If you are using a beta version, you may want to remove the AMD "Testing" watermark. Otherwise skip the next block of instructions.

Beta versions: Removing the AMD "Testing" watermark

Edit the ATI signature file via "nano" or "gedit":

sudo nano /etc/ati/signature

OR

sudo gedit /etc/ati/signature

By replacing the "UNSIGNED" line with the following code:

9777c589791007f4aeef06c922ad54a2:ae59f5b9572136d99fdd36f0109d358fa643f2bd4a2644d9efbb4fe91a9f6590a145:f612f0b01f2565cd9bd834f8119b309bae11a1ed4a2661c49fdf3fad11986cc4f641f1ba1f2265909a8e34ff1699309bf211a7eb4d7662cd9f8e3faf14986d92f646f1bc

Make sure to save before/on closing the file.

That will remove the AMD "Testing" watermark (which you will now never see) from the bottom right of your screen when you reboot (source).

Now go ahead and reboot your computer.

If all is right, the fglrx driver that corresponds to AMD/ATI Catalyst will be installed and working on your system. To confirm the drivers are working open a terminal and type:

fglrxinfo

You should get an output similar to the following:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4300/4500 Series
OpenGL version string: 3.3.11631 Compatibility Profile Context

Note: If you see any mention of MESA in the output, the fglrx drivers have not been installed correctly. See the troubleshooting section for more details

You can make configuration changes through the AMD/ATI Catalyst Control Center. It can either be found in your Application menu or you can launch it through a terminal like this:

sudo amdcccle

IMPORTANT NOTE:

Be aware that when you manually install fglrx, this can subtly break your system, since the packaging system isn't made aware of your changes.

The Launchpad developers get many bug reports from users who do this and then later discover after a few upgrades that their system starts behaving weird because of those fglrx remnants.

share|improve this answer
2  
Just so you know, the line sudo sh amd-driver-installer-*.run --buildpkg Ubuntu/precise can be replaced with sudo sh ./*.run --buildpkg Ubuntu/precise –  Adam Sack Mar 2 '13 at 6:54
    
On Ubuntu 12.10 with Beta Driver 13.3, the /etc/ati/signature watermark fix only worked when the code was entered WITHOUT a newline at the end and WITHOUT any trailing whitespace. When I copied and pasted I accidentally grabbed some whitespace & it didn't work at first. –  Toby J Mar 23 '13 at 18:03
2  
ADD "no need for 32bit systems" ABOUT "sudo apt-get install ia32-libs" BECAUSE LINK: "askubuntu.com/questions/143904/…;. COMMENT POSTED SUCCESFULLY. EXIT? [Y/n] –  yinon Mar 23 '13 at 21:52
1  
It worked excellent! –  Alejandro Sazo Jun 10 '13 at 0:46
    
I tried using this to install the latest driver (13.1) and got a "BadRequest" error when testing with glxinfo (details here notepad.cc/maugixu11). Where is that troubleshooting section section? –  phunehehe Oct 19 '13 at 14:41

Installing the ATI Catalyst Drivers for 12.10

Important UPDATE (22nd October 2012)

Latest proprietary AMD Catalyst driver version 12.9 cannot be used with Ubuntu 12.10 If you have a AMD Radeon HD 2xxx-4xxx series card.

Drivers for these cards are now available in a separate branch called legacy series. Unfortunately these legacy drivers (version 12.6) have not been updated to work with Ubuntu 12.10. Ubuntu 12.10 comes with xorg 1.13 while these drivers have support for older xorg 1.12. So if you want to install these drivers in Ubuntu 12.10, you have to downgrade to xorg 1.12.

Source and get Legacy Drivers here (if above note applies to you


INSTRUCTIONS

Uninstall firstly the current AMD driver with these two commands:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

Note: You will need to install the drivers (following the instructions below) but first add the same dependencies described in the answer above for 12.04LTS.

Start now the installation of ATI Catalyst v# with these commands under Ubuntu 12.10 or older:

cd /tmp && wget -O amd-driver-12-6-x86_64.run http://www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
chmod +x amd-driver-12-6-x86_64.run
sudo sh amd-driver-12-6-x86_64.run

Then follow setup instructions:

Run next this command to finish the installation:

sudo aticonfig --initial -f

Then reboot your system:

sudo reboot

That's it!

share|improve this answer
    
Do the 12.10 ATI drivers work? –  jrg Nov 14 '12 at 1:39
    
@jrg I have been maintaining this Q&A and its up to date with regards to what Ive tested. I haven't tested 12.10 ATI yet so the answer is I don't know. I have some other things going on and wont get round to this for a while (I believe 12.11 Drivers are avaialble also) –  Stephen Myall Nov 14 '12 at 6:52
2  
With the hd 5670 card I had to skip driver 12.10 completely and install the beta 12.11. Instructions here askubuntu.com/a/206025/55564. With Quantal Quetzal the ati 12.10 driver was incompatible with unity and after login compiz would crash. –  thelastshadow Dec 9 '12 at 23:34
    
The AMD driver now for Linux is... version 13.1 link. I will try it out and then update this Q&A. –  Crimbo Jan 27 '13 at 22:10
    
I have now updated this Q&A... waiting for @stephen to push the changes. –  Crimbo Jan 28 '13 at 16:43

Installing the ATI Catalyst Drivers for 13.04

These instructions will install Catalyst v13.4, in order to see what is the latest available driver visit the Official AMD Website

Instructions

Check your card

Only RadeonHD cards are supported by Catalyst drivers.

To know which card is installed in your system type the following command in a terminal:

lspci | grep VGA

It may show you your graphic card.

Before continue please read first! Which Radeon cards are no longer supported by ATI's Catalyst:

  • Cards that no longer can make use of AMD Catalyst drivers and are limited to open-source drivers:

    ATI Radeon 9500-9800, Xpress200-1250, 690G, 740G, X300-X2500, Mobility RadeonHD 2300

  • Cards that doesn't work with AMD Catalyst in Xserver versions newer than v1.13 and Linux Kernel newer than v3.5:

    ATI RadeonHD 2x00 - 4xx0 cards

    These cards can make use of the Catalyst Legacy driver, but only if you downgrade your Xserver version. This can be done really easily by following the instructions given at LaunchPad. This PPA downgrades the Xserver and install a patched version of fglrx that supports kernel version 3.5.

Removing (purging) existing drivers

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Install Dependencies

  • For 32-bit systems:

    sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic fakeroot libqtgui4
    
  • For 64-bit systems:

    sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic fakeroot libqtgui4 lib32gcc1
    

Download Catalyst package

cd ~/
mkdir catalyst
cd catalyst/

In order to have the latest drivers installed check if v13.4 is the latest offered in AMD Webpage, if v13.4 isn't the latest you may want to manually download the drivers from there, extract the zip file to ~/catalyst/ folder and then skip the following first two commands and execute the last replacing the package name with the name of the extracted one in ~/catalyst/ folder

wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
unzip amd-catalyst-13.4-linux-x86.x86_64.zip
chmod +x amd-catalyst-13.4-linux-x86.x86_64.run

Install Drivers

Navigate to the extracted package (~/catalyst/), make sure it is the only .run file in that folder, and type in the following command

sudo sh *.run --buildpkg Ubuntu/raring

An AMD Catalyst window will open to deploy the .deb packages wait until it finishes and then execute this command to proceed:

sudo dpkg -i fglrx*.deb

Configuration

  • Generic Configuration

    This will work for most people

    sudo aticonfig --initial -f
    
  • Minimal Config

    A very basic /etc/X11/xorg.conf file might be what you need if you have a new card that's not fully supported by aticonfig. Here follows the entirety of a minimal xorg.conf file for the Radeon HD 6870:

    Section "Device"
     Identifier "ATI radeon 6870"
     Driver "fglrx"
    EndSection
    
  • X2/Dual GPU Cards

    Only use if you have an X2 card (e.g. 4870X2 or 5970) !!Do not use for two separate cards in crossfire!!

    sudo amdconfig --initial -f --adapter=all
    
  • Dual/Multi Monitors

    If you have a dual monitor display (also known as "Big Desktop")

    sudo aticonfig --initial -f
    sudo aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
    

    Be advised that you may need to manually set the correct refresh rate for your second monitor through catalyst. See this threat.

Before Rebooting

Just in case, write down these instructions for the case you get a black screen:

  • If the X server fails to start, switch to a new TTY using Ctrl+Alt+F2. Log in, and attempt to start the X server.

    sudo startx
    
  • If it fails to start, you will likely see a stacktrace, and immediately above it will be something along the lines of "Could not stat /usr/lib64/fglrx/switchlibGL" which means that you failed to copy the executables properly. Ctrl+C, and immediately copy the switchlibGL and switchlibglx executables to the fglrx folder in /usr/lib64/ or /usr/lib32/.

  • If all else fails, revert your xorg.conf and reboot:

    sudo cp /etc/X11/xorg.conf.orig /etc/X11/xorg.conf
    

    This should return your original display.

  • If anything worked, try these key combinations in this order:

Ctrl+Alt+F1 ; Ctrl+Alt+Backspace ; Alt+PrntScr+r ; Alt+PrntScr+s ; Alt+PrntScr+e ; Alt+PrntScr+i ; Alt+PrntScr+n ; Alt+PrntScr+u ; Alt+PrntScr+b ; and in the last case hold Ctrl+Alt+SysRq (SysRq usually is the same as Print Screen) and type very slowly R E I S U B.

Test your Installation

Restart your system and type in the terminal:

fglrxinfo

The output may be similar to this if everything went fine:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7900 Series (This line may be different depending on what graphics card you are using.)
OpenGL version string: 4.2.12217 Compatibility Profile Context 12.104 (This line may be different depending on what graphics card and Catalyst version you are using.)

Now try:

fgl_glxgears

If you experience issues or a hang, you may need to disable fast TLS:

sudo aticonfig --tls=0

That is it!

Source


share|improve this answer
    
Have you tested this? With what model? What are your results? –  Lucio May 16 '13 at 23:43
2  
Yes, I own a Radeon HD 7970, Ubuntu 13.04 64-bit, worked perfectly, although I read about people that didn't removed (purged) the existing drivers and had issues on start-up. I use Blender for 3D modeling and simulations, the performance increased when dealing with subsurface modifying (i.e. more polygons on the scene). –  Rodrigo Martins May 17 '13 at 12:55
3  
amdconfig and aticonfig are the very same command, you can use either. I preferred to use aticonfig because, don't know why, some systems can return this: amdconfig: command not found so it's better keep with aticonfig, although using the other one will make no difference. –  Rodrigo Martins May 17 '13 at 20:41
1  
@RodrigoMartins thanks for your explanations. My advice is to underline or bold paragraph about unsupported cards. Maybe this should be part of instruction, as the first point "check if your card is supported" with ready commands to get card model. I've just lost 2 hours of my life and then I read paragraph about unsupported cards <facepalm>. Solution with Tomasz Makarewicz PPA is great, works perfect (downgrade of XServer)... –  s3m3n Jul 7 '13 at 17:42
2  
If I change sudo sh *.run --buildpkg Ubuntu/raring to sudo sh *.run --buildpkg Ubuntu/saucy will these same instructions work for 13.10? –  Chris Carter Oct 20 '13 at 13:21

There is yet another approach. We maintain a PPA called x-updates which provides updated drivers for stable releases.

https://launchpad.net/~ubuntu-x-swat/+archive/x-updates?field.series_filter=precise

This is really the best way to update drivers since:

a) it's a lot easier to install (just flip on a ppa and upgrade),

b) it won't break your system when you upgrade,

c) you can still file bug reports and expect support from Ubuntu.

Unfortunately, as you can see, we don't have -fglrx in there for precise, and the versions we have for past releases are a bit dated themselves.

This is because the official maintainers like me tend to be laz...ahem busy with the development release and/or bugfixing for the LTS, so don't often get to updating this PPA. But, we are very encouraging and supportive of community members to help us with maintaining this PPA. We have the procedure all documented to the degree that it's largely push button; if you can understand and perform the steps described in the other answers here, and you know how to use PPAs, and have an ATI system you can test your packages on, you already have the necessary skills. It's just a matter of getting to know you so we can trust you. We'll be happy to coach and mentor you, all you need to bring is care and dedication.

Of course, if you are only interested in updating your own machine, this all probably sounds like a lot of extra effort. However, it only requires one volunteer to take on this duty and then it simplifies life for everyone. Check out how many views this question has gotten so far - over 10,000. So one volunteer here can make a humongous difference.

share|improve this answer
    
When I try to add the PPA, I get this: Cannot access PPA (https://launchpad.net/api/1.0/~ubuntu-x-swat/+archive/x-update) to get PPA information, please check your internet connection. I am connected to the Internet, I can post this comment just because I am connected :P –  Sheikh Aman Jul 5 '12 at 11:04
1  
That link mentions Nvidia & not ATI?!? –  fleamour Aug 20 '12 at 1:16
    
I get the following error: sh: 0: Can't open /usr/share/ati/fglrx-uninstall.sh –  Good Gravy Dec 20 '12 at 20:51
    
If it installs ok, you can ignore that error. I think the installer checks for that to detect previous installations. If it prevents you from installing the driver, then file a bug report. –  Bryce Dec 21 '12 at 1:49

Install the device driver by:

sudo apt-get install xserver-xorg-video-ati

Then reboot.

share|improve this answer

protected by Community Jun 25 '12 at 11:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.