Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What are my options? Can I make the fans run more, can I make the CPU do less work, is it my graphics card? IBM T60 with Core Duo, ATI graphics


share|improve this question
Some has the same problem, it may be a problem with ubuntu's fan control. or maybe a bad process taking too mush resources. try TOP command in the terminal and take a look at the highest process – Prasad RD Apr 22 '12 at 14:43
It's a long shot and I'll recommend you try everything else before, but there might be a bug in the kernel (I know there was a problem like this with the Linux Mint 11 LXDE) and you can resolve it with an upgrade. But I repeat, it's a long shot. – Marius Balaban Apr 22 '12 at 14:49
used top, the only thing using a lot of cpu/memory is chromium. Everything else is negligible. I should add that it doesn't seem like it's going to catastrophically overheat, it's just uncomfortable to the touch. – Jones Apr 22 '12 at 14:51
and the kernel I have is 3.0.0-17-generic – Jones Apr 22 '12 at 14:52
I wouldn't say it's a long shot that an upgrade would fix the overheating. 3.0 kernel is well-known by now for power-management issues. The problem is that upgrading may cause other problems. If you have other things wrong with your laptop, then you might consider 12.04. You can even wait one week for the release. – Chan-Ho Suh Apr 22 '12 at 16:45
up vote 3 down vote accepted

It seems you (and I) have the same problem as most users using Intel processors. There is a power regression/overheating bug with Linux kernel used by 11.10. Good news is this bug has been fixed as witnessed by 12.04 beta 2 users.

Just upgrade to 12.04 on April 26 which I'm sure will take care of this problem once and for all. Hope this helps!

share|improve this answer
Alright that sounds like a plan! Thanks! – Jones Apr 22 '12 at 20:31
You are welcome. Trust me I know frustrating this is. 12.04 I read has dealt with it. – Mysterio Apr 23 '12 at 0:19
@jones, so how did it go, did the heating problem get solved in more recent versions? – Hermann Ingjaldsson Jan 6 '13 at 20:58

Try installing lastest propietary drivers for your ATI graphics, Open-Source drivers are known to make some cards (especially on laptops), work at higher temperatures, Catalyst 12.3 or later could fix this overheating problem.

ej. In my laptop, temperature went from 75°C to 44°C with propietary drivers.

share|improve this answer
How can I install the proprietary ones? I looked in the "Additional Drivers" under Preferences, but there's no way to add/change the graphics driver – Jones Apr 22 '12 at 17:18
Can you specify which graphics cards does your computer have? – crackout12 Apr 23 '12 at 3:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.