Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu 12.04 and wanted to use the gnome 3 shell, according to this site it was just a matter of installing the gnome shell as gnome 3 is already part of ubuntu 12.04

So I did sudo apt-get install gnome-shell and logged out, selected gnome and logged in and I was looking at gnome 2 instead of 3. What went wrong?

share|improve this question
2  
If GNOME 3 thinks your system isn't up to it, it will degrade to a GNOME 2 setup ("fallback mode"). –  geekosaur Apr 22 '12 at 11:55
    
Could you please open a terminal and post the output of gnome-shell --replace? (Open another one and type unity --replace to get Unity back when you're done testing.) –  zpletan Apr 22 '12 at 12:13

4 Answers 4

up vote 2 down vote accepted

gnome-shell requires some level of 3D hardware-acceleration to work.

It doesn't have to be special hardware - integrated graphics should in almost all cases be fine. But 3D acceleration must be working.

Gnome 3's window manager, mutter, is a compositing window manager that is OpenGL accelerated.

If gnome-shell doesn't detect that you have the right capabilities, it'll load into a "fallback mode" which means it loads an old-style panel that looks like Gnome 2 and it doesn't use a compositing window manager.

Ubuntu has helpful ways of installing proprietary drivers for graphics - have you tried these?

share|improve this answer

What the OP is seeing is the "old gnome 3". Gnome 3.4 is using llvmpipe to support older hardware.

Here is what gnome-shell now looks like in fallback mode (screenshot is taken with an intel GMA500 using the psb_gfx driver, which is 2d only).

gnome-shell

As of my post today, the latest versions of gnome-shell and llvmpipe have not yet been fully ported to Ubuntu or a ppa.

There is a ppa for llvmpipe, but because llvmpipe is under rapid development it is currently better to build it from source (git).

See How to install LLVMpipe?

share|improve this answer

I had the same problem. If you're using an ATI Radeon graphics card like me, this might be the solution:

http://onubuntu.blogspot.ca/2011/10/manually-removing-fglrx-from-ubuntu.html

Here's a copy/paste of the important bits:

~$ sudo apt-get purge xorg-driver-fglrx
~$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
~$ sudo dpkg-reconfigure xserver-xorg
~$ sudo apt-get install --reinstall xserver-xorg-core
share|improve this answer

This thread just saved me thanks! Full story:

Fresh install of Linux Mint 13 (Maya) on a Lenovo Thinkpad T520 with this driver : 01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [Quadro NVS 4200M] (rev a1)

I got gnome-shell with 3D working.

$ sudo apt-get install gnome-shell gnome-session gnome-tweak-tool

I switch to nvidia (I am a sucker for pain) : [http://forums.linuxmint.com/viewtopic.php?f=59&t=154932][1]

This works great for my external monitor but totally hoses my laptop display. For maybe the wrong reasons I decide to revert to revert to nouveau

$ sudo apt-get purge nvidia*
$ sudo apt-get install xserver-xorg-video-nouveau xserver-xorg-video-all
$ sudo rm /etc/modprobe.d/nvidia-installer-disable-nouveau.conf

This leaves me without openGL so gnome goes into 2D fallback mode. I verify this by running the gnome-shell --replace:

$ gnome-shell --replace
...
Xlib:  extension "GLX" missing on display ":0.0".
...

Following the steps to reinstall / reconfigure glx from above:

$ sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
$ sudo dpkg-reconfigure xserver-xorg
$ sudo apt-get install --reinstall xserver-xorg-core
$ sudo reboot

And I was back in business!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.