Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well, since I was so stupid to install the java via terminal with official package, it stuck on the licence agreement screen, because I had to accept it, but no key from my keyboard worked to accept. So I've closed the terminal, killing my install. Now it says in newly opened terminal java is installed, but does not display in software center. The problem is, I want to uninstall it to get to the software center one.

Some more info: Why do I want java actually? Because I recently upgraded my graphicscard from onboard to radeon. So, my MineCraft would actually load up, but as soon as it has to load a map, it crashes. I looked in the log file it leaves behind, I don´t see any issues with my graphics, it says there is something wrong with my java. Can´t post output here because I've deleted the files. Since java isn´t working, I cannot create a new one. On my onboard card it worked, but it doesn't play good because that thing came out of '06. So since I've installed my official radeon drivers and plugged in my card it stopped working. My graphicscard isn´t broken too, because it still worked in Win 7. I had working the openjdk runtime 6 (which I meant in previous part too) on my onboard. I had to uninstall that, and install the official, which I think was the most worse choice, because I also could have reinstalled runtime 6 or even 7 from software center. Maybe the output from java -version could be handy:

java version "1.6.0_23" 
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-0ubuntu1.11.10.2)
OpenJDK Client VM (build 20.0-b11, mixed mode, sharing)

So, how could I uninstall an unfinished! install of java via terminal?

If needing more info, just ask for it!

share|improve this question
    
what command did you use to install it? –  Alvar Apr 22 '12 at 10:39
    
sudo apt-get install python-software-properties, sudo add-apt-repository ppa:ferramroberto/java, sudo apt-get update, sudo apt-get install sun-java6-jdk sun-java6-plugin, those come from this site: superuser.com/questions/353983/… –  Remy Apr 22 '12 at 11:56
    
try Ubuntu software center again to install if they say something about broken package try synaptic software manager under filter select broke and remove those packages in red then try again –  Sreevisakh Apr 22 '12 at 12:30

1 Answer 1

up vote 1 down vote accepted

you've installed the packages: sun-java6-jdk and sun-java6-plugin. to remove them just type:

  • sudo apt-get purge sun-java6-jdk sun-java6-plugin

if you want to install them again, then just type

  • sudo apt-get install sun-java6-jdk sun-java6-plugin

the purge command removes everything there is and clear all config files of those programs, so if you have a broken install a purge + a new install is recommended.

share|improve this answer
1  
Ok Thanks man will try :) I am very sorry but this doesn´t work for me. These are both commands and output: sudo apt-get purge sun-java6-jdk sun-java6-plugin E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? What to do now? –  Remy Apr 22 '12 at 12:11
    
@Remy do you have like update manager running? or Ubuntu Software center? try to reboot then try again. –  Alvar Apr 22 '12 at 12:22
    
Well, I discovered I just had to install again, not even removing. This because it didn´t detect any java while deleting. So now I installed it again, and found out I had to move with my arrow keys to select the OK button to accept. Now it is installed and I could Run the game again, but still as soon it has loaded a map, it crashes. Meaning minecraft right now. So my actual problem isn´t solved yet. I thought I had to reinstall java, but yeah, that didn´t help. Any suggestions on this? –  Remy Apr 22 '12 at 12:37
    
is it crashing when you start the game or is it after like 5, 10 minutes of playing? what graphics do you have it set for? is your hardware good enough? –  Alvar Apr 22 '12 at 12:40
    
Well, it crashes not after a certain time, but after I load the map. I mean, the game starts fine, but I don´t get to the playable map. So, as soon the green line reaches the other side, my game crashes. My hardware is also good enough, because I have played it on lowest settings but still really good on my Win 7. Also, on my onboard card it worked with lowest settigs and like 10 fps, but still worked. Now it doesn´t. –  Remy Apr 22 '12 at 12:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.