Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'am running ROS on Ubuntu. When I tried to compile a package, errors occured. On the develop page, it suggested that we should update tinyXML to the latest version, which is 2.6.x. I typed sudo apt-get update first and sudo apt-get install libtinyxml on the command line, but I can only find 2.5.x version. I check the official website and make sure that the latest version is 2.6.2.

My Ubuntu is 10.10. How can I install libtinyxml 2.6.2 using apt-get?

share|improve this question
add comment

1 Answer

To compile packages you need the dev or devel variant.

Version 2.6 is not available in the official repositories. You need to find an unofficial repository or install it manually from the source. It shouldn't be hard for a library like tinyXML that has few dependencies.

share|improve this answer
    
Where can I find the unofficial repository for tinyXML? Thanks –  AlbertK Apr 22 '12 at 8:26
    
Well...I found a way to install tinyXML from .deb archive.ubuntu.com/ubuntu/pool/universe/t/tinyxml –  AlbertK Apr 22 '12 at 12:28
    
The location you linked is where apt downloads from... –  Janus Troelsen Apr 22 '12 at 12:39
    
Yeah, I know. But somehow I can't find and install this package by apt in my Ubuntu 10.10 –  AlbertK Apr 23 '12 at 15:37
    
it's probably belonging to an ubuntu version newer than the one you're using. –  Janus Troelsen Apr 23 '12 at 18:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.