Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 on my Mac VMWare Fusion (Version 4.1.2). The installation went fine and Ubuntu seemed to update itself during the install. After reboot I cannot get Ubuntu to access the internet via my Macs Ethernet connection (Connected to a router). I have tried to set the VMWare network adaptor to NAT or bridged and Host only without success.

In Ubuntu I have the eth0 set to Automatic DHCP. VMWare tools are installed as well.

I know next to nothing about what to do here and net searches on both Stackoverflow and Superuser sites are producing not results for me.

Could someone please help?

share|improve this question

2 Answers 2

The user noted in a comment that he wrote down the values of his IP address. He applied those to the configuration using NAT. Now the system seems to work.

share|improve this answer

I had this same problem, except I was on VirtualBox. I resolved it by configuring my VM in bridged mode.

I would make sure you check your DNS resolution on your guest OS, for example:

ping google.ca
ping 173.194.73.94

Try both pings, if the bottom one resolves it means you just need to configure the DNS on your guest OS.

If this is the case, you can easily use google's DNS servers and you should be up and running in little time.

Hope that help, cheers!

share|improve this answer
    
hi and cheers for your answer. I think something fundamental is wrong with the setup. Cant even ping the router address of 192.168.1.1 As a test I started another VMWAre machine and this time booted from the 12.04 Bootable disk (No install) This immediately has network and internet connection without me doing anything. Looking at its settings its setup for NAT on the VMWare host and the guest is Wired Conn etho0 - DHCP Automatic. Odd cause when I do this on the installed version nothing happens. Says cable unplugged. –  John Cogan Apr 22 '12 at 6:37
    
That is indeed ... weird!Try: dpkg-reconfigure ifupdown but that has no guarantees. I found info at the very bottom of this ubuntu networking help page on bridge mode. I was wondering after reading that if your Mac needs to be configured for bridged mode. Maybe not, since another VM was conencted with live cd. Good-luck! –  stefgosselin Apr 22 '12 at 6:50
    
Thanks Stef. Got this to connect now. What I did was note down the IP4 values and then applied these in my install on the wired config, Manual. Using NAT. Seems to be working, not sure though what will happen the next time I dial up. Thanks Anyway. –  John Cogan Apr 22 '12 at 7:00
    
It was a pleasure. I'm happy to see you have things running. –  stefgosselin Apr 22 '12 at 7:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.