Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used Sony Vaio VPCEA23en with graphics card ATI Radeon HD 5145 and have been using Ubuntu 11.10 and recently upgraded to 12.04 beta, however the problem of overheating (60-70) still persists. I have installed the graphics driver properly. Are there some features of Ubuntu that cause this problem? I would have no problem uninstalling them; Or will using a lighter version of Ubuntu (lubuntu) solve this problem?

Right now I am using Win7 and would like to switch to Ubuntu ASAP.

Snapshot using Lubuntu

share|improve this question

closed as off-topic by Braiam, Eric Carvalho, karel, Eliah Kagan, minerz029 Jan 10 at 2:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Eric Carvalho, karel, Eliah Kagan, minerz029
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Incidentally, you might think you're using the proprietary graphics driver, but you should check you're actually using it. For example this person found even after installing the proprietary graphics driver for his Sony Vaio, Ubuntu wasn't using it. Others, including me, find that Ubuntu sometimes hang onto using default drivers (graphics, wireless, etc.) even after installing the proprietary ones. –  Chan-Ho Suh Apr 22 '12 at 9:24
    
To check the driver you're using, type lspci -v into the terminal. Look for the section that starts with "VGA compatible controller" and see what is listed as "kernel driver in use". –  Chan-Ho Suh Apr 22 '12 at 9:31
    
the kernel driver in use is listed as radeon –  nischayn22 Apr 25 '12 at 11:53
    
Ok , I did the fix and now it shows fglrx but still the temp is about 63 –  nischayn22 Apr 25 '12 at 16:47
1  
Type top into the terminal, which will show you the most CPU-intensive processes. Do this after logging in, so you have a "fresh" start with no major apps having run. If you are still experiencing overheating, make careful note of the processes (if any) using up the most CPU. In particular, do you see something with compiz in it? –  Chan-Ho Suh Apr 25 '12 at 20:57

3 Answers 3

You should really check your power manager settings to make sure you are actually giving the laptop a break. A lot of the defaults are set for desktops really. It is why I was calling for a laptop distro for lubuntu... alas I got tumbleweed.

If that doesn't work try this: **Correction: sorry I had not picked up your graphic card was not a nvidia card. Please follow the instruction in the linked reference for information on how to install for radian. Unfortunately, it is a bit more long winded. Make sure you download for 64bit if that is what your distro is (and vice versa)

Reference

EDIT: After re-reading your post I am quite sure that it is more likely to be your power manager settings causing the issue. Either way install the latest driver though, but check your power first so you know for future reference.

EDIT: Go to start>applications>power manager

If you cannot find it yours will be either

gnome-power-manager

xfce4-power-manager

apmd

Is my guess, but if you can't find it, go into synaptic and search power and tell me which ones are ticked.

power manager basically allows you to configure the default settings for your battery. I have mine on suspend when the lid is closed or when I am not using it. I am using the xfe one. Let me know how that goes.

Link to my blog page with screen shots

Be careful when installing packages too. Always check they are right for your version. Ubuntu sort of dump them all in once place and leave it to us to check.

share|improve this answer
    
what power manager settings are you talking about? what should be done in there? –  nischayn22 Aug 15 '12 at 13:33
    
@nischayn22 I will look through steps and try to explain in my post –  Magpie Aug 15 '12 at 13:38
    
I don't get what can power management do to make my fan run all the time, and the high temperature –  nischayn22 Aug 15 '12 at 16:14
    
your fan is running because your computer is hot. I suspect your computer is hot because it has not got the right setting for power. Regardless of whether or not I am right you do need to sort out your power because that will be adding to the situation at best. Ubuntu is not like windows and the defaults will be for a desktop so you need to tell it what to do. –  Magpie Aug 15 '12 at 16:22
    
its xfce4 one, I have made the setting to be suspend when not lid closed, do I have to check anything else? –  nischayn22 Aug 15 '12 at 16:31

I Googled 'Ubuntu overheating laptop' and it is a HUGE problem. I fixed mine by installing Jupiter: http://itsfoss.com/install-jupiter-ubuntu-1304/ Keep in mind that this is an performance applet, so set the performance to 'power saving'. An alternative but may also be helpful is TLP found here under 'Improve battery life and reduce overheating' at the link at the end. Lastly you may want to check for graphics card updates or installing propriety drivers. Found here under 'Install additional drivers in Ubuntu 13.10' http://itsfoss.com/things-to-do-after-installing-ubuntu-13-10/.

share|improve this answer

First of all I recommend you to update to Ubuntu 13.10 as it is the first to fully soport Hybrid systems like yours, once said this:

Your graphics driver is not properly installed, you have not installed pxpress, do the following:

sudo apt-get install fglrx fglrx-pxpress

TLP helps laptop reduce the ammount of power consumed in a much more efficient way than any other:

First: Uninstall laptop mode tools

sudo apt-get remove laptop-mode-tools

Then install:

sudo add-apt-repository ppa:linrunner/tlp
sudo apt-get update 
sudo apt-get install tlp tlp-rdw

Finally start it:

sudo tlp start
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.