Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am using Ubuntu Lucid + kubuntu-desktop. NVidia works fine. Screensavers set to autostart & worked fine after initial install. Now screensaver attempted to start (brief flash of black only) but since quit doing that.. All screensavers work fine in Test mode. Is there a file entry that controls this?. kde/autostart is empty - should there be an entry here? Would the log files show up any relative errors? I am a newbie & the log info is way out of my league! Have not found any relative posts here or other forums. I would appreciate suggestions.

share|improve this question

1 Answer 1

Make sure kscreensaver is disabled: System Settings -> Display and Monitor -> Screen Saver -> Make sure that Start automatically after: is unchecked.

Make sure xscreensaver is installed. You should have a Screensaver option in settings menu. Activate the xscreensaver you want to use.

In your user directory ~/.kde/Autostart/ create the file named: xscreensaver.desktop containing the following lines:

#!/usr/bin/env xdg-open
[Desktop Entry]
Exec=xscreensaver -no-splash
Name=XScreenSaver
Type=Application
X-KDE-StartupNotify=false

Log out and log in again. xscreensaver should work fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.