Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When the trackpad stops responding, this leaves me unable to do anything, including shutting down. Is there a fix?

share|improve this question
    
There are many reasons your trackpad might not work. can you give more details, such as what you were doing when it stops and how often this seems to happen? Please also state the version of Ubuntu and MacBook Air you are using. –  Chan-Ho Suh May 18 '12 at 6:54
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 21 '12 at 22:03
add comment

closed as off topic by Jorge Castro, fossfreedom May 21 '12 at 22:03

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Known problem, after updating and rebooting the problem usually gets fixed. Here are instructions on how to do all that using the keyboard.

  1. Press CTRL+ALT+T. This should bring up a terminal.
  2. sudo apt-get update
  3. sudo apt-get dist-upgrade
  4. sudo reboot
share|improve this answer
add comment

sudo nano /etc/X11/xorg.conf

Section "InputClass"
    Identifier      "Apple Magic Trackpad"
    MatchIsTouchpad "on"
    MatchUSBID      "05ac:030e"
    Driver          "synaptics"
    Option          "VertScrollDelta"  "50"
    Option          "HorizScrollDelta" "50"
    Option          "MinSpeed"         "0.6"
    Option          "MaxSpeed"         "1.3"
    Option          "AccelFactor"      "0.08"
    # these two options are for multiple monitors 3:1 ratio.
    Option          "VertResolution"   "1"
    Option          "HorizResolution"  "3"
    Option          "SHMConfig"        "True"
EndSection

/etc/init.d/lightdm restart

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.