Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've gone a step further than most and added to the background-1.xml file that lies in contest folder. (Which is here). Everything seems to be fine, but when I want to change a my wallpaper to the one that cycles, neither any of the images are there, nor is there a button to chose the cycling wallpaper. see here

Can anyone help?

share|improve this question
up vote 1 down vote accepted

You should two .xml file,one is under /usr/share/gnome-background-properties/yourxmlname.xml ,the other is at /usr/share/backgrounds directory. Your background files should usually placed at /usr/share/backgrounds.

You can reference orginal Ubuntu wallpaper setting to modify your file.

share|improve this answer

Have yiou tried setting the permissions of your image(s). Go to the image repository (which I am assuming is usr/share/backgrounds) right click on the image and select properties. Set the permisiions tab and ensure the "Others Permission" is not set to "None" It should be set to "Read" or "Read and Write"

share|improve this answer

One of the XML files can be made fairly simply, the other is a complete bloody pain. This question is months old but since it was one of the top hits for this search I'm posting this here for future use. Run this perl script in a directory of images that you want to include. It'll output an XML file you can use.

use Cwd;
use strict;
use warnings;

print "<background>
my @list = glob("*");
my $dir = cwd();
@list = map {$dir .'/'. $_ }@list;
for(my $i=0;$i<(scalar(@list)-1);$i++){
print "<static>
print "</background>";
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.