Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 11.04 through USB stick on my Asus X54H laptop.Every thing is going fine but sometimes the system hangs up with the complete black screen,after that it does not respond any keys.Can some one tell me how it is doing like this?How to solve this?Any help will be highly appreciable.

share|improve this question
I think your laptop is going to more heated. So it can be hanged. – Ghost Answer Apr 27 '12 at 5:04
Nope..I don't think like that.I have checked that issue.. – newuser Apr 27 '12 at 5:06
Have you noticed when your system goes hang means on some particular tasks or after a fixed time period. – Ghost Answer Apr 27 '12 at 5:14
no..It hangs anytime..Sometimes it hangs without any tasks just by in ideal conditions – newuser Apr 27 '12 at 5:18
It may be due to RAM. If you can open your laptop then remove RAM, clean it and placed again. I hope your problem might be solved. – Ghost Answer Apr 27 '12 at 5:31

Is there a reason you are using 11.04? With the new release of 12.04 out, perhaps it's worth trying a more up to date version.

share|improve this answer
The same version is working good with another system so I think there is no problem with that I think. – newuser Apr 27 '12 at 14:39

If using unity then try unity --reset. Else Observe if system hangs up on starting particular application. Also just try making new user account and use that (Some user specific setting might have gone wrong).

share|improve this answer
how to make unity --reset.I don't have any idea about that.Can you describe that? – newuser Apr 30 '12 at 3:59
if you are using ubuntu then ctrl+alt+t for terminal. It can be even found under accessories. – Ravi Ranjan May 1 '12 at 17:47

Many people had this problem with ASUS(boots to black screen)

Try this:

Go to BIOS > Security> I / O interface Security> "New interface card". Set it to Locked.

I also had this problem before but after I did that Ubuntu worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.