Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an ETPS/2 Elantech Touchpad which works fine in Windows.

Since my first install of Ubuntu, and even now on Kubuntu, it randomly autoclicks.

Even the type of click is random, because sometimes it just moves my caret, but it also happens that I find something pasted in the wrong place, as if it autoclicked with two fingers (2 fingers tap pastes from clipboard).

I removed KMouseTool, believing that it's accessibility features where the problem, but I still got it, so I don't know what to do.

Is there any solution?

It's making hard to work with netbeans because it pastes code at random -.-

Thanks :)

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The problem might be due to the fact that your hand accidentally touches the touchpad while typing and it clicks. Go to System > Preferences > Mouse > Touchpad and uncheck 'Disable touchpad while typing' and 'Enable mouse clicks with touchpad'

share|improve this answer
    
I'm absolutely sure that my hand doesn't touch the touchpad while I'm writing, but I've found the option you said in synaptiks manager and now it seems ok! –  StepTNT Apr 21 '12 at 10:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.