Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

About a week ago, I upgraded my Dell Optiplex GX520 from 10.04 Lucid Lynx to 10.10. Unfortunately, I excitedly ignored all the warnings about how it was a beta release and I'm now stuck with a big problem: the screen resolution is way too small.

Right now, when going to System->Preferences->Monitors, I see 1024x768 listed as the current display setting, with the only higher setting being 1360x768 (which is useless as it just squeezes the screen). Before the upgrade, everything looked fine- I was able to view certain websites without a horizontal scroll bar, but after the upgrade, the entire interface looks oversized and I can't seem to find a way to change it.

Is there some way I can downgrade the OS, or even my version of whatever package manages screen resolutions, so I can "reset" it to how it was working before the upgrade? Or is there any other fix that I can do?

EDIT

Running xrandr returns the following:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096 VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1360x768 59.8
1024x768 60.0* 800x600 60.3 56.2
848x480 60.0
640x480 59.9 59.9

This is basically what I saw in System->Preferences->Monitors... except that it looks like with a maximum of res of 4096x4096, I should be able to make it higher.

Thanks for any help in advance.

share|improve this question
    
This page should be somewhat helpful. You probably have Intel 950 onboard video, if you have not added a video card. wiki.ubuntu.com/X/Config/Resolution –  charlie-tca Nov 10 '10 at 2:21
    
Thanks for the link- I've update my question to reflect what happened when I tried that. –  Archio Nov 10 '10 at 2:27
add comment

3 Answers

up vote 0 down vote accepted

I solved this by just giving up on 10.10... I backed up my comp and reinstalled 10.04.

Hopefully Canonical will fix this problem soon.

share|improve this answer
add comment

Updated:

Run

 sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

Then update via update-manager

share|improve this answer
    
When I added "nomodeset" after "quiet splash" and then pressed CRTL-X, the computer booted up with what looks like command-line mode... I logged into that and typed "startx" to see if I could show the user interface, but it gave me something along the lines of "no monitor detected". –  Archio Nov 10 '10 at 11:00
    
When I ran the command you listed, it returned this: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 643DC6BD56580CEB1AB4A9F63B22AB97AF1CDFA9 gpg: requesting key AF1CDFA9 from hkp server keyserver.ubuntu.com gpg: key AF1CDFA9: "Launchpad PPA for Ubuntu-X" not changed gpg: Total number processed: 1 gpg: unchanged: 1 –  Archio Nov 10 '10 at 21:57
    
I then updated & installed the packages, restarted, but to no avail. –  Archio Nov 10 '10 at 21:58
add comment

sounds like driver issue or a failure to detect monitor type. Are you using ATI or nVidia GPU cards? If so have you tried to use the "System" -> "Administration" -> "Additional Driver" to find proprietary drivers?

share|improve this answer
    
Additional Drivers returns "No proprietary drivers are in use on this system."... –  Archio Nov 10 '10 at 2:20
    
When I typed lspci, it returned "Intel Corporation 82945G", so I'm not sure which card this means I have... sorry if I'm not clear about this, I'm not very good with hardware. –  Archio Nov 10 '10 at 2:22
    
have you enabled the X org update PPA in Ubuntu Tweak or added the below PPA on your own? deb ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick main #X Updates –  hansioux Nov 10 '10 at 5:48
    
Is deb a command that I need to run? How would I add those files? –  Archio Nov 10 '10 at 11:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.