Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 11.10 and I've got this here GTK theme which is pretty nice, and I like the title bars and everything, but I've got a problem.

Every menu in the entire system has this weird and annoying translucent effect. I don't want this effect.

I've pored through the gtkrc for the theme for hours now and turned up nothing, I've googled and googled, I've tried editing the pixmaps to remove the transparency but nothing I do makes any difference.

Each time I make any change, I reload the theme by changing it in xfce-appearance-settings and then changing it back. I have confirmed this does reload the theme properly by making other minor changes.

Does anyone know how I can remove the transparency from this theme?

Here's a pastebin of the gtkrc if it helps: http://pastebin.com/QVa6LPZN

Pastebin of menubar.rc: http://pastebin.com/S91cQ3T5

Pastebin of panel.rc: http://pastebin.com/PQghvPUy

Dropbox of ~/.config/xfce4: https://www.dropbox.com/s/b3vwcrohi0zdcb2/xfce4.tgz

Below is depicted a screenshot of the problem, demonstrated using a pop-up menu. Note that it applies to all menus - application menus, the main application menu and pop-up menus.
Background faded and image zoomed/cropped to highlight the issue, otherwise unedited Screenshot of the problem

As you can see, the page behind the menu is visible through the menu - this is what I do not want.

How I installed it:

~/Downloads$ tar xzf 58426-Fawn.tar.gz
~/Downloads$ cp -R Fawn ~/.themes/

I then used xfce4-appearance-settings and selected Fawn from the menu.

I tried editing the pixmaps in ~/.themes/Fawn/gtk-2.0/Menu-Menubar/ and exploring the gtkrc in ~/.themes/Fawn/gtk-2.0/.

share|improve this question
    
Have you checked out the details for the mist engine? –  Martin Owens -doctormo- Apr 23 '12 at 14:13
    
@MartinOwens-doctormo- Could you elaborate on what your proposed solution would involve? Apart from the mist engine. –  Chris Browne Apr 23 '12 at 19:18
    
@Matthew gnome color chooser already has the Engines->Global box unchecked. I'll get those files for you now. –  Chris Browne Apr 25 '12 at 10:33
    
@ChrisBrowne - I've applied Fawn and your XFCE configuration - no joy - I get the correct - "no see through theme" and fonts as per your picture. Thus I doubt this issue is with the theme itself. What is your graphics card (lspci | grep VGA) and what graphics driver are you using (and installed from where?)? –  fossfreedom Apr 25 '12 at 15:10
    
Mobility Radeon HD 4200 is the card, the driver is fglrx from the official repos - version 2:8.881-0ubuntu4.1 I'm told, by apt-cache show fglrx. –  Chris Browne Apr 25 '12 at 20:22

2 Answers 2

What you're looking for is a Compiz configuration for transparent menus. One place you can get access to it is in Ubuntu Tweak -- Tweaks tab -- Compiz Settings -- Menu Effects -- check box for Enable transparent menus. You can install Ubuntu Tweak at:

http://ubuntu-tweak.com/

share|improve this answer
1  
xubuntu does not use compiz unless the OP has manually installed this and is using compiz --replace in his startup scripts –  fossfreedom Apr 23 '12 at 22:53
    
I have compiz installed but afaik it's not running - ps au | grep compiz doesn't list it as running. I only installed compiz for emerald in a previous bout of theming attempts but since realised that the theme I wanted was available as a native xfwm theme so disabled compiz and emerald. –  Chris Browne Apr 25 '12 at 10:26
    
xfwm4 --replace takes a second to reload but has no effect on anything - as I say, I'm all but certain that xfwm4 is the current window manager. –  Chris Browne Apr 25 '12 at 13:38

From your screenshot - perhaps just double check that you haven't got your opacity of popup windows slightly transparent (assuming you are using the default compositor)

enter image description here

share|improve this answer
    
Nope, this setting is set all the way to Opaque - I tried moving it further towards transparent and back again just in case, but it had no effect. Thanks for trying though! –  Chris Browne Apr 23 '12 at 19:16
    
... does this occur only on this theme or all themes? Have you got "enable display compositing" ticked? If yes - what happens if you untick it? If not - what happens if you tick it? Are you using Compiz as your composting window manager? –  fossfreedom Apr 23 '12 at 19:18
    
I do have "enable display compositing" ticked, and no I'm not using compiz as my compositing window manager. If I untick "enable display compositing", it solves this issue but gives rise to several more, so I'd rather not resort to disabling compositing if that's at all possible. –  Chris Browne Apr 25 '12 at 10:29
    
hmmm... this sounds like a bug in the compositor. To see if I can reproduce this I will need the contents of the folder and all subfolders and their contents from ~/.config/xfce4 - can you tar and dropbox this? –  fossfreedom Apr 25 '12 at 11:42
    
... one more question (to find out if this is user specific or not) - if you create another user account and install your theme into .themes - does this problem reoccur? –  fossfreedom Apr 25 '12 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.