Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Just yesterday took the plunge into Linux and Ubuntu. I loaded up 10.10 on my computer and managed to "make" the programs I needed but find an issue with the AC97 sound card. All day and most of the night and day today I tried all the tips and nothing. It seems 10.10 isn't playing nicely with this program :( The program is DSD1.4.1 found here: http://wiki.radioreference.com/index.php/DSD - actually it is links to the two required files under DOWNLOAD. The mbelib-1.2.3-src.tar needs to be worked first as DSD requires this to operate. I got it all done, did the "make" and when I try to run it I get the following:

Digital Speech Decoder 1.4.1
mbelib version 1.2.3
ioctl reset error
ioctl speed error
ioctl stereo error
ioctl setfmt eror
Audio In/Out Device: /dev/audio

I learned today from another user that the two prior versions of Ubuntu work but that 10.10 doesn't. As I said I tried all the tips on both sites but no luck. My internet connection is too slow to DL anything as large as this (17 hours) so I am a bit stuck! The other user also had the exact same issue using 10.10, and the sound still works, just not using the program DSD.... very odd. Hoping someone here can figure out whats going and maybe a fix for it. I later found out it seems no sound cards are working properly but can't verify this one. It does only happen with version 10.10 though.

Thank you in advance! John

share|improve this question
    
Does your sound work with other programs? –  User Nov 10 '10 at 3:18
add comment

2 Answers

The flag here lies in the last line of output that you provided; it demonstrates that the program uses the older, deprecated OSS interface that was removed in 10.10. Have you tried using padsp $program (where $program is the name of the executable that you ran to obtain the output that you included above)?

share|improve this answer
add comment

In my experimentation here, padsp does not work with DSD.

there are certain types of binaries that padsp doesnt work with (type man padsp for details) and I'm fairly convinced that dsd is one of them , though lack the coding skills to prove it

regression to ubuntu 10.04 LTS will fix fix john's problem

there is a rumour (ubuntu forums) that killing /dev/audio was done as a temporary bugfix that got overlooked in the release, but I have yet to see a fix for it

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.