Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install utimer (https://launchpad.net/utimer) by following the below steps.

$ tar -zvxf utimer-0.4.tar.gz
$ cd utimer-0.4
/utimer-0.4$ ./configure
/utimer-0.4$ ls 
aclocal.m4  autogen.sh  config.h.in  configure     COPYING  depcomp   INSTALL     Makefile.am    Makefile.in  mkinstalldirs  po      README.in
AUTHORS     ChangeLog   config.log   configure.ac  data     Doxyfile  install-sh  Makefile.decl  missing      NEWS           README  src
/utimer=0.4$ make
make: *** No targets specified and no makefile found.

How shall I proceed?

Also tried,

/utimer-0.4$ ./autogen.sh
========= Preparing uTimer ============
======== Running autoreconf ===========
./autogen.sh: line 3: autoreconf: command not found

Installed autoconf. It installed 4 new packages - autoconf automake autotools-dev m4

But I get another error.

========= Preparing uTimer ============
======== Running autoreconf ===========
Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 196.
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
aclocal: couldn't open directory `m4': No such file or directory
autoreconf: aclocal failed with exit status: 1

How should one proceed when 'makefile' is not generated?

Thanks.

share|improve this question
    
What should I do when make file is not created? It was my guess that autoconf will work (i don't even know what it is). Is it the correct way to proceed when make doesn't work. –  John Apr 20 '12 at 16:18

2 Answers 2

up vote 5 down vote accepted

try install autoreconf by following:

sudo apt-get install autoconf
share|improve this answer
1  
tried. I have updated my post. –  John Apr 20 '12 at 16:22
sudo apt-get install libtool 

(for libtoolize)

share|improve this answer
1  
Thanks a lot for providing an answer, but can you please explain why this particular package is needed here? –  Chris Wilson Jan 29 '13 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.