Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since the install of Ubuntu Desktop 10.10, any launched programs shows up without a windowborder.

I update daily, but the problem remains. Until now I found only one "remedy" that fixes the problem (until the next reboot). This "remedy" is not logical to me and is something I just stumbled upon.

On the desktop I choose with a right mouseclick for the option 'Change Desktop Background'. When this window popsup I choose the last tab for 'Visual Effects'. Then I choose any of the options other then 'normal'. The program starts looking for a driver, but fails to find any. At the moment the program reports this back to me.... surprise......all the windowborders are visible and stay that way until I reboot.

I can not explain this, but I would like to find a real and permanent solution to this problem.

share|improve this question
    
Can I please clarify the following: does this happen consistently, every time you log in, or intermittently? Do you normally have "visual effects" set to normal, or none? –  jmtd Dec 16 '10 at 13:31
    
Do you still have the problem. Have you found how to solved the problem or considered accepting an answer that solves your problem (if any)? –  Luis Alvarado Dec 5 '11 at 18:58

7 Answers 7

Sometimes this problem shows up to me too. I found out a workaround for this. If you have the Compiz Fusion Icon installed (package fusion-icon) you can click on it with the right button and then click on the 'Reload Window Manager' option. This always works for me.

Sure it's not the solution for the problem, but it might help you until it gets fixed. And I'm sure there is a command which reloads the window manager without having to install the fusion icon, but I don't know it. If anybody knows the command please post a comment.

share|improve this answer

It's a graphics card driver issue. The driver you are currently using isn't working nicely with compiz. what graphics are and which driver are you using?

share|improve this answer
    
The graphics card is a ATI Radeon HD 4650. The videodriver is a standarddriver used by Ubuntu 10.10 and is named: Messeltronik Dresden GmbH 24" 60 Hz. The resolution is set to 1920x1080 (16:9). I have tried the latest driver from ATI for this graphics card, but then I have an other problem. After installing that driver not the whole monitor is used. In other words I get a smaller screen to view with a black border around it. –  Poldor Nov 10 '10 at 13:58

It is random problem, caused by driver and timing issues with upstart. More quick workaround (for me) is Alt-F2, then type metacity and Enter.

If that happens every boot, you can add

sleep 10 && metacity --replace

to your startup apllications.

share|improve this answer
    
Sorry, I have tried both options, but problem is not fixed. –  Poldor Nov 10 '10 at 13:48
    
Try compiz --replace –  Extender Nov 10 '10 at 14:45

I've seen this in two situations, the first:

I've had that issue twice in Maverick (10.10) now, both times caused by an incompatible libdecoration0, which comes with compiz. To see if you've got the same error I did, when Gnome starts, type compiz --replace (in a terminal, so you can see stdout output). To fix this, I removed the version of Compiz I'd upgraded to 0.9.0 and 0.9.2 (at different times) and rolled back to the 0.8.6 version which came at install.

The second (probably more common), relates just to the install of my nVidia drivers and attempting to use the nvidia xorg driver when the kernel DKMS kernel module has been compiled/loaded correctly. Thankfully, nowadays this is a two line fix (simply reinstall the nvidia drivers to rebuild the DKMS module):

apt-get purge nvidia-glx-185
apt-get purge nvidia-glx-185 nvidia-settings

Of course, your setup involves and ATI card and fglrx driver, but it's probably worth giving the above a go (substituting Nvidia for ATI of course). See if you can get an error/log readout too.

share|improve this answer

the following always does the trick for me:

compiz --replace

If above doesn't does the trick, then try:

gnome-panel --replace

share|improve this answer

It happens to me sometimes, I just hit ALT+F2 and type

gtk-window-decorator --replace

Try this solution for permanent fix:

Launch the Terminal and type:

sudo apt-get install compizconfig-settings-manager

-After the installation go to System>Preferences>CompizConfig Settings MAnager (from the menus on top).

-scroll down until you find Window decorations.

-find Command and use one of those:

/usr/bin/compiz-decorator

OR

gtk-window-decorator --replace

This should fix it for you.

share|improve this answer

At one stage in upgrading the xorg drivers for my video card (through daily updating), compiz uninstalled itself. Through trial and error I have found two ways to fix this issue.two things can fix this.

First...

sudo apt-get install compiz

if that doesn't work, sometimes this will fix it.

sudo dpkg --configure -a

updates break my video card drivers all the time. Happend twice in the last week (though I'm playing with the Natty alpha.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.