Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't know if this is the right place to put this question. I installed Lampp and followed this instructions http://www.apachefriends.org/en/xampp-linux.html#377 and everything worked fine until i rebooted the computer and this happened

MySQL error

It can be because of i rebooted the computer while lampp was on.

Anyone that can help?

EDIT:

I can run php files. It's just phpmyadmin that doesn't work

And i get this in http://localhost/xampp/

enter image description here

Maybe this has something to do with it.

jeggy@jeggy-XPS:~$ sudo /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
jeggy@jeggy-XPS:~$ sudo /opt/lampp/lampp stop
Stopping XAMPP for Linux 1.7.7...
XAMPP: XAMPP-Apache is not running.
XAMPP: XAMPP-MySQL is not running.
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.
share|improve this question
    
What happens if you enter sudo /etc/init.d/mysql start at the command line and retry? –  jippie Apr 20 '12 at 7:18
    
sudo: /etc/init.d/mysqld: command not found –  Jeggy Apr 20 '12 at 7:20
    
Does /opt/lampp/lampp exist? Can you enter /opt/lampp/lampp start and retry? –  jippie Apr 20 '12 at 7:25
    
In the windows client there is a button / menu in the xampp admin to start components at XAMPP startup. Not sure where to find it here. –  jippie Apr 20 '12 at 7:39
    
/opt/lampp/lampp startmysql from the command line, but you should be able to configure it as a defualt. You can also choose to add a second line to the rc.local script as below, but I think that looks messy. –  jippie Apr 20 '12 at 7:41
show 3 more comments

3 Answers 3

up vote 0 down vote accepted

Type

sudo /etc/init.d/mysql stop
sudo /opt/lampp/lampp restart

The problem is another mysql daemon is running.

You might also need to stop the systems apache service too. [/etc/init.d/apache2 stop]

share|improve this answer
add comment

Add /opt/lampp/lampp start to /etc/rc.local, after the comments and but before the exit 0.

share|improve this answer
    
Bad advice as your webserver (part of LAMPP) obviously does start, otherwise you couldn't have a screenshot like that. –  jippie Apr 20 '12 at 8:04
add comment

got this same error due to my dumbness.. not rebooting but reinstalling without stopping the service(s) first I think... kinda new to running this locally... setup passwords then couldn't access localhost.. so I tried to reinstall.

the stopping servers in init.d advice doesn't work.

sudo: /etc/init.d/mysql: command not found (for example)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.