Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im trying to download Bitcoin for my Ubuntu Oneiric.

 sudo add-apt-repository ppa:bitcoin/bitcoin
 sudo apt-get update
 sudo apt-get install bitcoin/bitcoin

Everything goes smooth until the install line.

 Reading package lists... Done
 Building dependency tree       
 Reading state information... Done
 E: Unable to locate package bitcoin

Help! I've never done a PPA before!

share|improve this question
add comment

2 Answers

I got it installed and working with these. Open a terminal and run the following commands:

  • Add the Bitcoin Ubuntu PPA repository in your Ubuntu:

    sudo add-apt-repository ppa:bitcoin/bitcoin
    
  • Update package lists

    sudo apt-get update
    
  • Install bitcoin-qt

    sudo apt-get install bitcoin-qt
    

Ready! Look for Bitcoin under "Applications menu"

share|improve this answer
    
working solution, thanks :) –  superbDeveloper Mar 12 '13 at 19:23
add comment

The problem appears to be the apt-get install command you gave:

sudo apt-get install bitcoin/bitcoin

Looking in the PPA, the package you want is just called bitcoin, so this is probably what you wanted to type:

sudo apt-get install bitcoin
share|improve this answer
1  
I did that. I got the same error. –  Will Apr 20 '12 at 3:12
    
Okay. Two things to check: (1) was there any errors printed by apt-get update? and (2) What does apt-cache policy bitcoin show? Try editing your question to include this info. –  James Henstridge Apr 20 '12 at 3:14
    
$ apt-cache policy bitcoin N: Unable to locate package bitcoin> and there was one error in the update: W: Failed to fetch download.tuxfamily.org/syzygy42/dists/feisty/… 404 Not Found [IP: 88.191.250.171 80] –  Will Apr 20 '12 at 3:18
    
That download.tuxfamily.org update error looks unrelated (although you may as well remove that source -- even if it worked you probably don't want to install software targeted at Ubuntu 7.04). I'm left wondering whether the PPA was actually added correctly. Were any errors returned by the apt-add-repository? –  James Henstridge Apr 20 '12 at 3:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.