Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I went out of the room while I was trying to update from 11.10 to 12.04 LTS. When I came back, my laptop had gone into sleep mode. I assume that it was half way through updating something. The screen would be black but would flash up with my background if I moved the mouse or pressed a key on the keyboard.

I restarted my computer and when I booted up the Ubuntu partition I was told,

GLIBC_2.14 is not found and is needed for /lib/libply.so.2

Then I was booted into some kind of recovery shell (I’ve forgotten exactly what it was called). From there, I tried to see whether the system could just pick up where the upgrade left off. I typed do-release-upgrade -d but simply got something like

[Errno 30] Read Only file system when trying to access '/root/.cache/update-manager-core'

(Note: This is not the exact wording.)

From there, I went onto the Windows partition (where everything seems as normal). Then I went back to Ubuntu in recovery mode and tried to recover packages with dpkg. It ran and said that to fix some problems I would need to manually run dpkg --configure -a. I went to the recovery shell and tried this, and was told that I couldn’t do it because of a ‘Read-only file system’.

I’m running a HP Pavilion dv6 which started with Windows 7. I added Ubuntu on after a while. Note that sudo doesn’t do anything in the recovery shell.

What should I do to get out of this situation and complete the upgrade?

share|improve this question
    
I think this is not a problem with your laptop going into sleep mode, I think this is surely a bug with the 12.04 cannonical update. I am facing the same problem I was running 11.10 and upgraded to 12.04LTS and was sitting right in front of my laptop till the installation finished. After rebooting its giving a message that MY file system is read-only and it is not finding GLIBC_2.14 and even dpkg --configure -a saying read-only file system. –  rao_555 May 2 '12 at 11:40
    
+1 for reporting this immediately –  rao_555 May 2 '12 at 11:40

2 Answers 2

boot into the recovery shell again and mount -o remount,rw / that will remount the filesystem read/write. Then you can try to repair your system.

share|improve this answer
    
didnt worked for me! –  user204653 Nov 17 '13 at 12:05

I don't know how to respond using the account I used to ask the question but I used the command that ruediger suggested and it worked fine. If anyone is interested I then used apt-get install -g and this sorted everything out. There my be a little bug with updating but nothing that breaks my computer, Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.