Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu is within a virtual machine.

When I log in with a ubuntu session, the web browser works fine. But when I log in with a xfce session, the web browser does not work... I try to change proxy setting, it gives me:

When running Google Chrome under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem launching your system configuration.

But you can still configure via the command line. Please see man google-chrome for more information on flags and environment variables.

Could anyone help?

share|improve this question
add comment

2 Answers 2

There's a command line option --proxy-server - so it should be possible to run chrome using a terminal window, using the command

google-chrome --proxy-server="<proxy-name>:<proxy-port>"

Another solution would be to set the environment variables:

http_proxy=<proxy-name>:<proxy-port>
https_proxy=<proxy-name>:<proxy-port>
export http_proxy
export https_proxy
google-chrome
share|improve this answer
add comment

I am getting the same error, when I click change proxy settings. It says,

When running Chromium under a supported desktop environment, the system proxy settings will be used. However, either your system is not supported or there was a problem launching your system configuration.

But you can still configure via the command line. Please see man chromium-browser for more information on flags and environment variables.

Can anyone help/ Thank you in advance.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.