Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual boot installation with Windows 7 Ultimate (32-bits, NTFS file sytem) and Ubuntu 10.10 (32-bits, ext4 file system). I have installed the version 7.0a of Truecrypt in both Operating Systems.

Located in the Windows 7 HDD I have a 150 GB encrypted file container. It is a standard and dynamic file container, which means it's not hidden and uses a sparse file. This file was created using the Windows version of the Truecrypt program. When I logon in Windows the container is mounted as the drive E: and everything works fine!

In Ubuntu the Windows's NTFS file system is automaticaly mounted after I logon. I've configured that using the ntfs-config package. In my ~/.profile I have this line to mount the truecrypt's file container:

truecrypt /media/7EDEBCFADEBCABB1/Users/Wagner/hd/hd.tc /media/truecrypt1

The file container is mounted after the logon without any problem. I can access it, copy files to/from it, etc. But when I try do copy relatively large amounts of data (>~50 MB) to it via nautilus or cp -R, it starts the copy, copies some data until certain point and then it just hangs! The progress bar does not move anymore and nothing happens. There is no error, it just hangs and that's it. I have to kill the process myself.

This problem does not happen in Windows: I can copy very large amounts of data to the container and it works great. But in Ubuntu the problem always happens! I mean, whenever I try to copy a bunch of files together the copy process hangs.

Does anyone ever faced this problem? Can anyone help?

Thanks!

share|improve this question
    
Apparently, it has to do with these dynamic container files. I have just tested the same situation but using a 5GB static container file and the copying didn't hang up. Guess I'm going to use smaller static containers to protect my data. –  Wagner Maestrelli Nov 9 '10 at 20:30
add comment

2 Answers 2

up vote 1 down vote accepted

This is a problem with dynamic file containers can you should certainly report the problem to truecrypt:

http://www.truecrypt.org/bugs/

Even though you may have solved the issue, it's worth reporting that you got caught out with the problem without any information about what might be happening.

share|improve this answer
    
I've just submitted an issue report. Thank you for this tip! –  Wagner Maestrelli Dec 7 '10 at 23:21
add comment

I have versions of the TC 7.1 and the same thing happens with Ubuntu 11.10 with copying large files. When copying large files from one virtual disk TrueCrypt (ntfs partition) on the second disc tc (ext4 partition) crashes the system. In text mode the system is not responding. Is solved by the installation of the new kernel 3.2. Now the system is not suspended

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.