Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently had some issues with my wireless. Ubuntu is detecting the wifi card and the kernel module is loaded and I can even turn the wifi on and off from the menu up in the top right (this is in gnome shell, but the behavior is the same in Unity). However, I can't get a single wifi network to show up and I can't connect to any wifi network by manually entering the SSID.

If I boot into OS X, the wifi works fine.

Here's what I have from iwconfig:

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

here's lspci:

03:00.0 Network controller: Broadcom Corporation BCM4331 802.11a/b/g/n (rev 02)

I'm not sure what other info might be needed. I haven't tried a whole lot since I haven't seen these particular symptoms anywhere else. I have restarted the laptop numerous times, logged out and in, reloaded the kernel module (b43) all to no avail.

share|improve this question

closed as too localized by Eric Carvalho, AgentCool, Luis Apr 28 '13 at 15:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did the wireless stop working right after the upgrade to 12.04? Because, if so, then my laptop did the same thing. –  B Johnson Apr 27 '12 at 14:55
    
It seems that there is a correlation, but I was using 12.04 beta for a while without issues. I didn't have this problem before 12.04 though. I can't really pinpoint what day I got updates that might have caused this. It also seems like the issue has more or less gone away, but I'm not 100% sure yet ... –  greggory.hz Apr 30 '12 at 15:14
    
This question appears to be abandoned and unanswered. If you solved it, please post an answer explaining how it was solved (answering your own questions is not merely permitted, but encouraged when there is no other answer that does the job). If the question no longer applies you may voluntarily delete/close it. –  Eric Carvalho Apr 25 '13 at 1:06

Browse other questions tagged or ask your own question.