Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a custom package I've built, python-amqplib, which relies on python >= 2.5. I'm using repoman to push to my repo via Jenkins, which reports the build was pushed successfully. After an apt-get update it shows when I run apt-cache search python-amqplib.

However, I can't install it nor does anything show up when I run apt-cache show python-amqplib.

Here's what it spits out when I try to install it:

# apt-get install python-ampqlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-ampqlib is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package python-ampqlib has no installation candidate

Here's what apt-cache policy shows:

# apt-cache policy python-amqplib
  Installed: (none)
  Candidate: 1.0.2-4-4
  Version table:
     1.0.2-4-4 0
        500 mycompany-staging/main Packages
     0.6.1-1 0
        500 lucid/universe Packages
share|improve this question

From your command above there appears to be a PQ - QP mismatch in the spelling, is that just a paste typo?

Is it the case that Apt is set to always prefer lucid? (Is does not appear as such from the apt-cache output though...) Does:

apt-get -t mycompany-staging install {python-ampqlib,python-amqplib}

make any difference?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.