Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 beta, and after installing the gnome-shell each time before i log in, when I select Gnome desktop, I get the gnome backfall (classic) desktop.

I also noticed that I cannot enable compiz, (I could with the 10.10 version), I dont know if it has something to do with the drivers.

I have a intel i3 processor

share|improve this question
    
What's your graphics card? If there is any proprietary graphics driver, do you have enabled it? –  jP_wanN Apr 18 '12 at 20:24
    
1, Have you installed mutter?, 2.Gnome Shell can possibly be used with Compiz though it's not the correct way for the Shell to work it uses Mutter, 3.In my experience Gnome Shell fails to load with an AMD graphics card. –  Uri Herrera Apr 18 '12 at 22:14
    
Almost certainly something wrong with your graphics card configuration. It is not enabling compositing, because your graphics driver is either missing or not configured properly. –  Gary Apr 19 '12 at 2:34
    
My computer has a Nvidia GT325M with Nvidia Optimus, but never enabled the propietary graphics (neither when I had ubuntu 10.10 & compiz & shell working) and being working always with the I3 internal graphics procesor wich has been always enough for my work in Ubuntu. –  Matheus Frik Apr 20 '12 at 9:02
    
I have just installed mutter and restarted, but still GNOME SHELL not starting, going to the FALLBACK version directly. –  Matheus Frik Apr 20 '12 at 9:03

2 Answers 2

If you are using an optimus based laptop, going to the Ubuntu Software Center and removing the "NVidia binary X.Org driver ('current' driver)" may solve the problem.

share|improve this answer
    
I dont have that driver installed –  Matheus Frik Apr 30 '12 at 22:25
up vote 0 down vote accepted

I managed to fix this issue installing bumblebee, after the restart everything is working correctly, Shell & Compiz on Gnome Classic

sudo apt-add-repository ppa:mj-casalogic/bumblebee
sudo apt-get update && sudo apt-get install bumblebee
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.