Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Kubuntu 10.04, with a few GTK apps (Pidgin, Evolution), and want to set Chromium as my default browser. I've set the default browser in KDE's System Settings to chromium-browser, which works for KDE apps.

For GTK apps I set the same setting in Gnome Control Center, but instead of opening in my existing Chromium window, links from the apps open in a new window, with a error about not being able to access my profile.

How can I make GTK apps use open links in the existing window?

Edit: I should also add that when the new Chromium window opens, the following error is displayed twice

Your profile could not be opened correctly.

Some features may be unavailable. Please check that the profile exists and you have permission to read and write its contents.

share|improve this question

3 Answers 3

I can't explain why, but today I logged in and everything was working as expected. Sorry I can't give more useful information than that, but perhaps I just needed to do a hard reboot for some reason.

share|improve this answer

There is a setting in the chromium browser. I recently removed chromium and installed chrome so cant say the exact location. Check "under the hood" may be there u find the option.

share|improve this answer
    
Thanks for your reply. Can you tell me what the setting that you're thinking of is called? –  marxjohnson Apr 18 '12 at 12:36

You need to do this:

chmod -R 775 ~/.cache/chromium
chmod -R 775 ~/.config/chromium 

This is what made everything to work and I am enjoying chromium even more than chrome stable!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.