Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently updated and found that Unity shows on the gnome-classic/fallback desktop. Is this a new feature (which I doubt to be), or a bug? If it is a bug, tell me how to disable Unity because it interferes with the lower panel (i.e. I bring out Trash instead of showing the desktop when I try pressing the "Show desktop" button when the panel is not in focus).

I don't encounter this problem in gnome-classic (No effects).

Don't judge me. I like pokemon!

Screenshot of Unity and GNOME Classic running at the same time

share|improve this question
    
Maybe check your start up Apps? looks to me like they are in the start up some how. –  zeitue Apr 18 '12 at 5:22
    
This looks more like Unity with a gnome2 panel than gnome fallback - How did you install gnome? –  jP_wanN Apr 18 '12 at 20:35
    
The only thing listed on my startup apps is wicd. And yeah it does look more like unity but it is gnome2. I wouldn't have a lower panel if I were not in a gnome2 environment. I installed gnome via software center. I think the packages were gnome-session-fallback and gnome-panel. –  jerowin Apr 19 '12 at 3:01
    
The bottom panel belongs to GNOME Classic, which is just a different shell for GNOME 3 meant to look similar to GNOME 2. I had this same thing happen once before to me while switching between sessions, but I don't know how to reproduce it or how to resolve it; the problem just went away on its own after a reboot for me. –  WarriorIng64 Apr 24 '12 at 2:53
    
you are a genius. How can I do that ? –  Suhaib Nov 23 '12 at 16:57

3 Answers 3

The difference between Gnome Classic and Gnome Classic (no effects) is that the former runs Compiz. It seems Compiz has a Unity plugin, which if enabled, will bring forth that panel and menubar that is annoying you. See this link I found on the Ubuntu forums. The poster there used CCSM to disable the plugin. I don't know if that's the best way (CCSM doesn't have a great reputation, to say the least). You can search this site for alternatives to using CCSM.

share|improve this answer
    
It's worth noting that starting in Ubuntu 12.04, it'll be more difficult to disable Unity from CCSM. This is meant to keep people from breaking their desktop inadvertently. –  WarriorIng64 Apr 24 '12 at 3:30
1  
Great find! My reading of what it says is that the checkbox has been moved so that people can't accidentally disable Unity while running Unity. Presumably the OP won't have an issue with this, since s/he's running Gnome Classic. –  Chan-Ho Suh Apr 24 '12 at 3:39
    
For the benfit of those wondering if this will work, this has worked for the OP, although s/he has not checked the answer as "accepted". –  Chan-Ho Suh May 19 '12 at 10:09

Maybe you have gnome-panel installed

You can uninstall gnome-panel to remove the gnome panel in the bottom!

share|improve this answer

On the login screen you will observe a small icon next to your name. Click it and select the appropriate desktop environment setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.