Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

I just upgraded from ubuntu 11.10 to 12.04. When I log in into Unity 3D and Gnome 3 I only get a wallpaper for few seconds and then the screen goes blank with mouse pointer showing. I can easily log in to Unity 2D and Gnome Classic (no effects).

I have Nvidia GeForce 7025 / nForce 630a/integrated/SSE2/3DNOW! Graphic card. I checked my card compatibility using /usr/lib/nux/unity_support_test -p and came out with following result:

jeevan@jeevan-System-Product-Name:~$ /usr/lib/nux/unity_support_test -p 
OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce 7025 / nForce 630a/integrated/SSE2/3DNOW!
OpenGL version string:  2.1.2 NVIDIA 295.40

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

After lot of reading and going through several post and also trying different solutions to it I am still not able to get Unity 3D working. I think the problem is with the Nvidia Graphic Driver 295.40 which is crashing Compiz. I tried to roll back to Nvidia 295.33 but it doesn't allow me to do so as it keeps asking to install from root. I cannot find anyway to login as root. I badly need help. I somehow want to get UNITY 3D running.

Any advice would be appreciated.

share|improve this question

marked as duplicate by Jorge Castro, hexafraction, Eliah Kagan, Mitch, Jacob Johan Edwards Oct 1 '12 at 13:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@jokerdino : I followed the steps in your posted URL and getting the following error while starting ccsm. The Application CompizConfig Settings Manager has closed unexpectedly. –  Jeevan Apr 18 '12 at 12:33
1  
restart your computer and try if it works. Sometimes, CCSM can crash. –  jokerdino Apr 18 '12 at 12:51
    
Ok I tried the following. First I tried restarting computer to see if it works. It didnt. Then I restarted again and logged in Unity 2d. I uninstalled compiz. I restarted again and installed compiz and unity. Still the problem persist. I think there is some bug within compiz as it is the one that is crashing. –  Jeevan Apr 18 '12 at 13:32
    
Relevant bug report - bugs.launchpad.net/ubuntu/+source/unity/+bug/963633 –  jokerdino Apr 18 '12 at 14:00

2 Answers 2

up vote 0 down vote accepted

I found a workaround to my problem. The problem was with the Nvidia Driver current version (295.40). I had to rollback to the previous version and find out if I can login to Unity 3D. I downloaded the older version of Nvidia Driver (295.33) to Desktop.

I restarted and logged into recovery mode. I selected the 'root' option and logged in as root. I installed the older Nvidia Driver (295.33) using following commandline

cd Desktop
sh ./NVIDIA FILE NAME.run

I followed the onscreen instruction and installed the driver. After installing I restarted the computer and this time I able to log into Unity 3D. :)

share|improve this answer
    
had same situation ... perhaps just reinstalling of driver can help plus lightdm reconfigure. though I forget try this method last time. just took fresh install of 12.04 beta2 through backup )) waiting for LTS release ... obviously it is many issues of unstable betas and weak migrate control –  swift Apr 21 '12 at 17:24

First try to login as guest/new user ... In my case (final 12.04) Unity-3D worked then. So the reason may rather be somewhere in the profiles than in the system/graphics ...

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.