Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to know if it's safe to update the firmware of my iPhone 4S through a Windows XP virtual machine created on VMWare Workstation 8 with forwarded USB.

Thanks.

share|improve this question
    
This site is dedicated to question related to Ubuntu and official derivatives. Check out the FAQ for more info: askubuntu.com/faq –  mikewhatever Apr 18 '12 at 4:38
2  
@mikewhatever, this question is on topic and relevant to Ubuntu (question is asking about running a WinXP VM on an Ubuntu host). I'm not sure about VMware, but I do use VirtualBox and I haven't had any (recent) problems with USB sync of iPhone/iTunes on Win7 guest. –  amc Apr 18 '12 at 4:50
    
post it on this site it is not meant for askubuntu apple.stackexchange.com –  Ashu Apr 18 '12 at 7:47
    
@amc +1 to your comment, but note that sync and firmware updates are totally different things. OP's question was about firmware, which is problematic on a VM –  Tom Brossman Apr 18 '12 at 7:55
add comment

1 Answer

up vote 4 down vote accepted

Short and simple answer:

No, it generally is not safe to upgrade firmwares through a virtual machine.

Having said that I have to admit that I have done firmware upgrades through a Virtual Box Windows guest (though not with an iPhone) without any problems. It may work fine in most cases. But as soon as the VM has proplems related to the virtualization you may end up with an incomplete firmware upgrade that may render your device unusuable.

Therfore it is recommended and much safer to upgrade a firmware by using another machine running with the OS the upgrade software is designed for.

share|improve this answer
2  
The last time I tried this I was using VirtualBox, not VMware. I couldn't get it to complete until I set an 'empty' USB filter, so the VM could see any USB device. Something changes with the USB connection when you do firmware upgrades, so watch out for this issue. –  Tom Brossman Apr 18 '12 at 7:49
1  
I also tried to update firmware on an iPad from VirtualBox and it also failed. I believe the reason is the one pointed out by @TomBrossman - the device's "identity" changes half-way through the process so the virtual machine does not see it anymore. Alhough the failed update didn't render the device unusable - i.e. it didn't boot anymore, but I was able to update it from a "normal" machine which fixed the problem. –  Sergey Apr 18 '12 at 8:09
    
I have done it with a VirtualMachine, but this is a very tricky thing to do and also risky. –  jrg Apr 18 '12 at 12:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.