Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i'm using my university connection I can't run apt-get update normally as I do at home or any other place.

Everything else (that use connection) works properly.

I've already tried to change the repositories provider to a local one (Brasil) and now i'm using the official Canonical repos.

It doesn't leave 0% [waiting headers] part.

How could I debug this? What should I tracert to find where the connection is goin down?

share|improve this question
2  
See if you can just browse the repo sites with a web browser. They may be black-holing or throttling those servers in particular. If they use Ubuntu at the university, they may drop traffic to known repositories so they can sort of enforce what's available in the local college repository. –  hbdgaf Apr 18 '12 at 1:26
    
@aking1012 - Yeah, I can browse the repositories on archive.ubuntu.com via my browser... they don't use Ubuntu here, but AFAIK they didn't blocked the connection... at least not intentionally –  TiuTalk Apr 18 '12 at 1:29
1  
Another possibility is that they dynamically shape traffic per website/url. This would make any multimedia sites and distribution update sites painfully slow(the more it uses the less it gets type of thing). You could try proxies, but that's complicated. <-- less likely, but there's a lab at a local community college where they teach an OS course and Windows update get's throttled by the barracuda system they have installed. –  hbdgaf Apr 18 '12 at 1:58
    
You can take a look at askubuntu.com/questions/135818/… but I'm not sure that problem results in a stall at 0% [waiting headers]. It is a current anomaly with apt-get update. –  John S Gruber May 22 '12 at 2:25

3 Answers 3

up vote 1 down vote accepted

I reinstalled the operating system and everything worked good... sadly i didn't figured out the problem.

share|improve this answer

If your university is slowing down traffic between your computer and specific Internet servers (one way of doing what has been suggested in the comments), then you could probably solve your problem by switching to a different download mirror.

The easiest way to change this is in the Software Sources window. I don't know what release/flavor of Ubuntu you're running so it's hard to provide optimal instructions for bringing that up graphically, but you can probably bring it up by running gksu software-properties-gtk.

share|improve this answer

Many universities run their own Ubuntu mirrors. You should ask around and see if there is a local mirror.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.