Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to run F@H on my Maverick machine. I've downloaded and installed the three .deb files from their official download page (fahclient_7.1.52_i386.deb, fahcontrol_7.1.52-1_all.deb and fahviewer_7.1.52_i386.deb).

Sadly, it seems like FAHClient has some missing dependencies:

$ FAHClient 
FAHClient: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

$ ldd /usr/bin/FAHClient
/usr/bin/FAHClient: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/bin/FAHClient)
    linux-gate.so.1 =>  (0xb78d4000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb789e000)
    libssl.so.1.0.0 => not found
    libcrypto.so.1.0.0 => not found
    libdl.so.2 => /lib/libdl.so.2 (0xb7899000)
    libexpat.so.1 => /lib/libexpat.so.1 (0xb7872000)
    libz.so.1 => /lib/libz.so.1 (0xb785d000)
    libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb784b000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb775f000)
    libm.so.6 => /lib/libm.so.6 (0xb7739000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb771d000)
    libc.so.6 => /lib/libc.so.6 (0xb75c0000)
    /lib/ld-linux.so.2 (0xb78d5000)

Is there a way to satisfy these dependencies with minimum impact on the rest of the system (something like this perhaps)? Or is my only alternative to try an older version of the client?

share|improve this question
    
Have you tried the suggestions here? Or are you the original poster in that thread as well? If you have tried them and they haven't worked, and you are not the OP there, then more information may help: (1) What happened when you downloaded and installed the client manually (from folding.stanford.edu)? (2) Is your Ubuntu system 32-bit or 64- bit? (If you're unsure, please provide the output of "uname -m"). –  Eliah Kagan Apr 17 '12 at 19:46
    
@EliahKagan: That's not me, but at least I'm not the only one.. It says there "You can run FAHClient v7.1.50 which was build with libssl0.9.8 and works on most Linux distributions.", but the .deb files for 7.1.50 are missing or I am too much of a dumbass to find them. I can't seem to find any 7.1.x files except for 64bit versions and 7.1.52... (1) As I mentioned in the post, all packages install ok, but the client doesn't start. (2) It's 32bit. –  dr Hannibal Lecter Apr 17 '12 at 22:04
    
I upgraded one of my 32-but Ubuntu systems running Folding@Home from version 6 to 7, and I got a similar message, but about libssl0.9.8. Installing that fixed the problem for me, but that might not be much help to you. As for finding download links for other versions or builds, you could change the version number in the download URL and see if that works (or for a different build, change the architecture, for example change amd64 to i386). –  Eliah Kagan Apr 18 '12 at 2:14

1 Answer 1

As Ubuntu 10.10 is now End of Life and no longer supported, as of April 10, you probably want to upgrade to a newer version. Specifically, Ubuntu 11.10 or 12.04, which have OpenSSL 1.0.x packaged, and where you'll find the libssl1.0.0 package, which this version of FAHClient needs. Also in your question, you should note that it requires a newer version of libstdc++, by the GLIBCXX_3.4.15 symbol missing.

share|improve this answer
    
Sorry, I should have mentioned in the question that I have no intention of upgrading. When Unity came in I left the building. I'm staying on 10.10 until Mint+Cinnamon or something similar becomes stable/usable enough. Anyway, is it your opinion that it's not possible to resolve this manually? –  dr Hannibal Lecter Apr 17 '12 at 19:38
    
@drHannibalLecter EOL releases are still supported here, so you may get an answer. But you should be aware that continuing to use an end-of-life release exposes you to security vulnerabilities, as there are no more updates for security bugs as they are discovered, exploited, and publicized. –  Eliah Kagan Apr 17 '12 at 19:52
    
@EliahKagan: I know it's a bit of a security risk, but I'm firewalled and have the system "fine tuned", so I'm now enjoying a period of stability. :) –  dr Hannibal Lecter Apr 17 '12 at 22:09
1  
@dobey While you're right that there are many options available for desktop environments in currently supported Ubuntu releases, it is not correct to say that the classic GNOME interface is still available. The GNOME 2 interface has been replaced with GNOME 3, which includes Unity, GNOME Shell, and GNOME Fallback. GNOME Fallback is similar to the classic GNOME 2 interface, but it is not the same, and since all versions of supporting libraries have been upgraded from GTK+2 to GTK+3, GNOME 2 is not supported in current Ubuntu releases and there is really no good way to install it. –  Eliah Kagan Apr 18 '12 at 0:52
1  
@dobey GNOME Fallback ("GNOME Classic") is sufficiently different from GNOME 2.x that many Ubuntu users are surprised and disappointed when they upgrade and find that it is not to their liking. If this is the forum to suggest people use GNOME 3.x, then this is also the forum to warn about that. –  Eliah Kagan Apr 18 '12 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.