Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Bit of a n00b still with Linux, but getting there...

Anyway, I've put a new install of Ubuntu 11 on an old P4 PC of mine I was hoping to give away and I'm having a little trouble with the on-board Intel 100/PRO VE network adapter, but I thought I'd cracked it.

After startup I run "dmesg | grep e100" to see what the kernel makes of the driver and get this:

[    1.756219] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
[    3.237229] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    3.237235] e100: Copyright(c) 1999-2006 Intel Corporation
[    3.237310] e100 0000:02:08.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[    3.259916] e100 0000:02:08.0: (unregistered net_device): EEPROM corrupted
[    3.277707] e100 0000:02:08.0: PCI INT A disabled
[    3.277735] e100: probe of 0000:02:08.0 failed with error -11

So I found out that by running the following I can make the driver load:

sudo modprobe -r e100
sudo modprobe e100 eeprom_bad_csum_allow=1

It loads and the adapter works great. However I don't want to next user to have to run that every-time they start the PC. So I learned that putting the option into a .conf file in the /etc/modprobe.d folder should set the option everytime it's loaded. I created the following file in /etc/modprobe.d:

-rw-r--r-- 1 root root   37 2012-04-16 21:18 e100.conf

and gave it the contents:

options e100 eeprom_bad_csum_allow=1

And restarted the machine. When it comes up the network is not working and looking at dmesg | grep e100 has the same message I had at the start.

Running "sudo modprobe -r e100" then "sudo modprobe e100" (without the options specified) makes it load great, so it does seem to use the e100.conf file.

Why doesn't it use it on startup?

Much appreciate any help, sorry it's so long but hope I've explained myself well.

Cheers, Chris.

share|improve this question

1 Answer 1

If a module is loaded at boot time (before the root filesystem is opened), you need to update the initial ramdisk. This is the first "filesystem" that is loaded, it will load drivers, discover and mount partitions, etc.

To update this initrd, run:

sudo update-initramfs -u

(this will automatically be called by kernel upgrades/installations, hence you need to run it only once)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.