Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

very new on Linux as well on Ubuntu. I have install in my PC the Ubuntu 11.10 and after a regular Ubuntu update, the Flash player cannot start.

I have uninstall the Flash player several times to tryother versions of the flash but still the flash cannot start in my browsers (I use both Firefox and Chrome).

Note that I install the flash player with browsers closed.

share|improve this question
1  
How are you uninstalling, and installing, the Flash player? Is your Ubuntu system 32-bit or 64-bit? –  Eliah Kagan Apr 17 '12 at 17:44
    
I am using the Software center to install and uninstall the Flash Player. Also I have try one time to download and install it from the Adobe web site. My OS is 32-bit. –  Merianos Nikos Apr 17 '12 at 18:14

3 Answers 3

These instructions assume the problem is not caused by a non-Adobe plugin for Flash, which in your case, given what you said, seems like a reasonable assumption.

First, completely remove the flash player by running this command in a Terminal window (Ctrl+Alt+T):

sudo apt-get purge adobe-flash\* flashplugin\*

Now, you should also remove all user-specific files created by Adobe Flash (and other Adobe software) before, which may be causing the problem:

mv ~/.adobe ~/.adobe.old
mv ~/.macromedia ~/.macromedia.old

Actually, those commands don't remove anything--they just rename the folders so Adobe Flash won't use them anymore. However, you can feel free to remove them afterwards.

Then install Adobe Flash. You can do it in the Software Center or with:

sudo apt-get update
sudo apt-get install flashplugin-installer

You have a 32-bit system so whether you install flashplugin-installer or adobe-flashplugin doesn't matter, but if you had a 64-bit system then it would be better for you to use the adobe-flashplugin package. The flashplugin-installer package only provides the 32-bit version of the plugin. (I'm providing command-line instructions for flashplugin-installer rather than adobe-flashplugin only because you might not have the software source for adobe-flashplugin--the partner repository--enabled.) By the way, some instructions say to install flashplugin-nonfree--that is equivalent to installing flashplugin-installer.

Since it doesn't work in either Firefox or Chrome, clearing user-specific browser files is probably unnecessary. However, if the above method does not work, you should see if the problem occurs in the guest account (or any other user account--you could even create a new account to test). If the problem did turn out to be user-account-specific, then you'd want to clear browser-specific files to see if that would solve the problem.

share|improve this answer
    
thanks for your answer. I have follow all the above instractions but stil the problem occre. Also I have logged in as guest and the problem still ocure. Any other solution please ? –  Merianos Nikos Apr 17 '12 at 21:01
1  
@MerianosNikos Please run this command in the Terminal and paste the output into your question: dpkg -l | egrep 'flash|gnash|swf|lightspark' That will provide information about Flash plugins including non-Adobe Flash plugins that might be causing problems. –  Eliah Kagan Apr 18 '12 at 6:05
    
This is the respone : ii flashplugin-installer 11.2.202.233ubuntu0.11.10.3 Adobe Flash Player plugin installer –  Merianos Nikos Apr 18 '12 at 7:13
1  
@MerianosNikos Well, you don't have any non-Adobe plugins for Flash.... Try running sudo apt-get purge adobe-flash\* flashplugin\*, then when that's done, open the Software Center and install the package adobe-flashplugin. Then log out and back in (or reboot). If that doesn't fix the problem, please perform all the instructions in my answer again, but this time select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it either into your question (editing your question) or at paste.ubuntu.com (and give the URL here). –  Eliah Kagan Apr 18 '12 at 14:57
    
Ok, I followed the above instructions but nothing chaged. Here is the paste of the terminal paste.ubuntu.com/935686 . Note that I use greek language in my installation, and I have try to make a draft translation of the messages. –  Merianos Nikos Apr 18 '12 at 16:48

I had exactly the same problem.

Try to install this add-on on firefox :

https://addons.mozilla.org/en-US/firefox/addon/flash-aid/

After installation, click on "quickmode" and "install stable flash". It will open your terminal, remove the old version and install the new one.

Good luck!

share|improve this answer
    
I already have use it, and doesn't work. :( Any other idea ? –  Merianos Nikos Apr 28 '12 at 16:35
    
This add-on had been removed, so the answer is outdated, methinks. –  theUg Dec 22 at 0:03

The best way to fix this problem is to download the latest google chrome browser, that's it.

Now my flash player is working properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.