Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a blank USB flash drive I want to put a new filesystem on. If I try adding a new partition it complains "No partition table found on device /dev/sdc". Creating a msdos partition table seems to work correctly, except that when I go to add a new partition it complains with the same error. What am I missing?

share|improve this question
If your USB flash is mounted, you should unmount it before partitioning. Sometimes Ubuntu will automount the flash when you select it in GParted. Is that the case? – OpenNingia Nov 9 '10 at 12:41
The device is not mounted. – Hew Nov 9 '10 at 12:59
What version of GParted (or Ubuntu) are you using? – JanC Nov 9 '10 at 16:18
Ubuntu 10.10, GParted 0.6.2-1ubuntu1. – Hew Nov 10 '10 at 10:30
up vote 3 down vote accepted

Trying using Disk Utility in the Administration Menu (command line: palimpsest) instead of gparted. You should be able to create a partition table with it or replace the existing one.

It's entirely possible they use the same libraries & access routines - if that fails i'd suspect your hardware is faulty.

share|improve this answer
Using palimpsest I experience timeout errors when attempting to format the drive. The best result I could get was formatting with "don't partition", but when I tried formatting as a FAT volume it would still display the drive contents as "unknown". It looks like the drive is faulty. Thanks for your help. – Hew Nov 10 '10 at 10:26
np. Try formatting ext2 just to see if you can get any use out of the device. Also check dmesg output; device errors will get logged there. – Broam Nov 10 '10 at 15:37

You can create it.Open Gparted, right click on allocated space of your USB flash drive and select New.Enter everything as you see in the snapshot below and click add.

alt text NOTE: Now fill all the fields as you see in the snapshot below and click add. alt text NOTE: Now goto Edit Menu and select Apply All Operations. alt text Now new partition is created.

share|improve this answer
The USB flash drive is currently "unallocated" space. I'm happy to make this either FAT or NTFS. I just need to know what to do to make it work! – Hew Nov 9 '10 at 13:24
very helpful..!! – roanjain May 28 '14 at 12:06

Ok, Hew, I too had the same problem when I first got the millenium hard drive enclosure to connect it to the computer via usb port.

Just follow these steps, and you need to be patient throughout.

  1. Open up GParted and choose your device.
  2. Click on Device > Create New Partition Table.
  3. Click on OK in the dialog window that appears.[NOTE: Do not click apply yet!]

  4. Then Right-click on the unallocated space, Create a new partition of the desired size. (Use all space available, but you can make separate partitions)

  5. When your done sorting out partitions and their sizes, click apply button.

Thats it. Process Complete.

All I wanted to say was, do all processes in one go, from the creation of the partition table to partitioning.

share|improve this answer
@JohnSGruber Well, i just shared what i did to make it work. And it worked the way i wanted it to and i no more care what caused it, coz after that, i got no more hitches from that hard drive. I wanted to tell that its some kind of bug in GParted which messes an external hard drive; U just have to create a partition table and allocate partitions all contiguously. <br><br> As for a partition table without definitions of at least one partition, man, have you ever read about the concept of sets, where a set has an element even when empty, NULL?? – Layman806 Apr 19 '14 at 10:06
I've removed the comment you are referring to--I'm not sure it was very accurate and I think it misled you. I said there wasn't a container to hold partitions, but there is an MBR that may hold the primary partitions. Irregardless, if one get's the message "No partition table found on device /dev/sdx" they should go ahead and follow your steps rather than letting the message stop them. I haven't had to avoid discontiguous partitions, by the way. Thanks for your helpful answer. – John S Gruber Apr 26 '14 at 20:10

Just make sure you dont create partitions on the disk if you plan to use it on windows. Window shas a problem with usb sticks having multiple partitions.

share|improve this answer
It's my experience that windows can only see the first partition. So if you make your first partition windows, and all the rest linux you shouldn't have any problems. Windows can't read linux anyway. – L. D. James Jan 6 '15 at 2:22

In some cases you may just have a fried stick.

I have a usb stick that no longer works after using it to install edubuntu with the pendrive utility. gparted and disk utility can't create a partition table, and windows can't read or format it. HP USB disk storage tool and bootice also fail.

share|improve this answer
Not sure why this is downvoted, the OP has said above that it turned out his drive was faulty. – Jamie Kitson Apr 19 '14 at 22:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.