Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What the hell is this ?!! Whats wrong with firefox ??!!

Intending to solve this issue I have deleted all my apache related programs from my system, though no problem is solved.

Im soo confused. Why firefox showing this wrong message ? I have checked /var/www I have this folder as I had apache 2.2. Now I dont have any webserver though Im seeing this message.

This message is only dislayed when Im trying firefox. No other browser (opera,rekonq and chrome) showing this , instead they are returning "could not connect to localhost," which is normal message.

I have tried to figure out whether I have any other instances of apache running or not using: $ ps a | grep apache and it rerturned "command not found."

How I can be sure where that application lies ? How can I stop it ?

I dont know how much damage I already made to other programs. Is there a way I can check all program dependencies and reinstall them ?? I think I have deleted several dependent programs.

share|improve this question
1  
Attach the output of dpkg -l | grep apache –  B. Roland Apr 17 '12 at 12:36
    
How did you "delete" Apache and the other depencies? –  jP_wanN Apr 17 '12 at 12:36
add comment

2 Answers

up vote 1 down vote accepted

If I understand your question correctly, you mean that even though you have no web site running any longer, Firefox appears to show that you do.

In this case, it sounds like the issue might be Firefox keeping a local cache of your page for you.

Step 1. Check if your site is being cached

To browse the FireFox cache and see if your site is listed as being cached, enter the following into your browser window:

about:cache

Look around for any sign of your server or page and see if anything's there.

Step 2. Turn of Firefox Caching

You can also ensure that the browser won't cache things by entering the settings page via entering the following into the browser window:

about:config

and setting the "network.http.use-cache" property to "false".

Step 3. Force a Non-cached refresh of the page in Firefox

You can do this by using CTRL + F5 on the page to refresh it and force a get from the server. You could alternatively use CTRL + Shift + R to accomplish the same thing.

share|improve this answer
add comment

Run sudo netstat -4lptn from a terminal window.

The output should be similar to:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      1344/apache2    
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      1035/mysqld     
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1344/apache2    
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      918/sshd        

Check for anything that contains 0.0.0.0:80 and note the Process ID/name.

If you do not have a similar line, the problem is with Firefox.

share|improve this answer
    
Using Synaptic I have removed apache and confirmed its deletion using those above commands. –  Curious Apprentice Apr 17 '12 at 14:33
    
This issue is fixed. I was having that issue due to two addons: One is "session manager" and the other is "tab mix plus." I cleaned my firefox's cache and cookies and the problem is gone. Session manager have kept a cached verion of that page I viewed earliar. –  Curious Apprentice Apr 17 '12 at 14:36
    
Good to hear that! Now I suggest you to add your comment as an answer and accept it, because it solved your problem. (Or accept goober's because it is more Firefox-related than mine and following that would have pointed out the cached page...) –  lgarzo Apr 17 '12 at 14:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.