Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every GTK3 theme I've ever tried other than Ambiance or Radiance has some "fallback" buttons when maximized instead of the theme buttons. Is there a fix or a theme without this issue?

Example:

Sample

share|improve this question
    
Not at all an isue with Ubuntu nor Unity, this is an issue of the Themes in question. –  Uri Herrera Apr 17 '12 at 22:09
    
I see your point, but considering that every theme tested had this issue, including those that were simple color modifications of Ambiance or Radiance, the problem seems more complex that that. It's as if the unity-2d panel checks which theme is in use and adds its own buttons. Also, consider that the maximized windows in the themes tested do work properly in Unity-3D, so the designers are taking unity into consideration. –  Veazer Apr 18 '12 at 9:07
2  
I just verified this theory. I made a straight copy of the Ambient theme and renamed it Ambo, and edited the theme files to reflect the name change. Despite everything being correct with the theme file Unity-2D cannot render maximized windows properly so indeed it is an issue with Unity. Image –  Veazer Apr 18 '12 at 9:32

2 Answers 2

up vote 2 down vote accepted

After further testing, at the moment the answer to my question seems to be no. It appears that the only included Ubuntu Ambiance and Radiance have the ability to render properly when maximized for the reason stated in my previous comment. This has been filed as bug #984818 at Launchpad.

Until this problem is fixed with the Unity-2D panel it not possible for any third party theme to work properly.

share|improve this answer

I have recently experienced the same problem in my netbook with unity 2d, and after searching the internet and failing in finding a solution for this, I had an idea which actually worked perfectly.

If you want the buttons of your custom theme working as they should just go to /usr/share/themes and rename the folder of your custom theme to Ambiance, you can also rename the original however you want, for example "Real Ambiance" to remember where it is in the case you want to revert the changes. Afterwards restart your computer and it should work, at least it did for me.

I have days in the linux ecosystem and therefore I have no idea why this might be, I just followed my frustration-leaded instincts, and thought that I should post the workaround here for the people that are suffering from this glitch.

Hope it helps.

share|improve this answer
    
Does it actually use the buttons from your theme or does it use buttons from the theme you replaced? –  Veazer Oct 25 '12 at 21:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.