Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 and prefer Evolution to Thunderbird as my mail manager and organiser. I run a gmail account and use the calendar a lot to organise future meetings,appointments and tasks.I have synced the calendar, contacts and meetings, but cannot get tasks to sync. Does anyone know how to do that?

share|improve this question
4  
Not with Evolution tasks, but you could maybe use google-task-indicator –  zetah Apr 17 '12 at 12:21
    
Thanks will give it ago –  user55339 Apr 18 '12 at 11:54
add comment

1 Answer

Tasks are currently not supported in Evolution due to missing support for Google Tasks in underlying library (libgdata).See the bug here.

But it can be done using third party tool syncevolution & web service memotoo.

Google <----------> Memotoo <-----------> Evolution.

First enable universe & multiverse repo. Then open terminal & type: sudo apt-get update. Install syncevolution: sudo apt-get install syncevolution sync-ui. Sync-ui is the gtk-gui for syncevolution.

Now go to https://www.memotoo.com/ & U can sign up there for free or choose premium version (1 Euro/Month).Free version has some limitation (max 50 tasks).

Sign in & go to "My Tasks" & select "syncronize my task". See image below.

enter image description here

Select Google Task from the list.Authorize memotoo to access your google account.Select type of synchronization "both ways". You can set sync schedule as per your preference.

enter image description here

On the same page click "synchronize google task" to start syncing manually.At this point you can see your google task on memotoo (default task category). Now you need to sync memotoo with evolution.

Open dash, type sync-ui & from the search open syncevolution.If you open it for first time you need to select the sync service.

enter image description here

Click on select sync service, Select memotoo from the list. Provide memotoo username & password. De-select appointments & contacts check-boxes & finally click "save & use".

enter image description here

Clicking Sync-Now under action will start syncing.If you are syncing for first time it may offer slow-sync.Click on "slow sync" to perform a slow-sync.You can also enable "Automatic sync" to sync automatically(syncevolution will be running in background). At this point, it will sync to your default task list.You can view default task list by typing "syncevolution" in the terminal.

enter image description here

enter image description here

Extra Tweaks:

You can choose to sync only uncompleted task between memotoo & evolution. To do that open syncevolution, edit memotoo, under server settings change task uri from "task" to "task.uncompleted".

enter image description here

DONE!

share|improve this answer
    
I got the following error in sync-ui when trying to sync with memotoo (own translation): "There was a problem with the local database. Restarting the syncronization or restarting program may solve the problem" –  wouter205 Jun 19 '12 at 16:54
    
Its a coomon bug in syncevolution. To fix it go to ~/.config/syncevolution/default/peers/memotoo/sources/calendar+todo & open the config.ini file with gedit.Make sure 'sync' is not set to "disabled". If that is case, change it to "two-way" or "slow"(i.e sync=two-way or sync=slow).Relaunch syncevolution.It should work now.Also you could try latest sync evolution from ppa.Add the repository to /etc/apt/sources.list as: deb http://downloads.syncevolution.org/apt stable main.Open synaptic & install the 'syncevolution-evolution' package. –  Khurshid Alam Jun 22 '12 at 10:51
    
@wouter205 Also you can explicitly set your local database to evolution database(This is NOT recommended).First make a backup of ~/.config/syncevolution/sources/calendar+todo/config.ini file. Then open it with gedit & change the database value to Personal, (i.e database=Personal).It will sync to your task-list named "Personal" which is default task-list in evolution. –  Khurshid Alam Jun 22 '12 at 11:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.