Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the following warning message from a new installation of Ubuntu 10.04 (server version) on an HP Proliant DL380 G5:

Your CPU appears to be lacking expected security protections.

  $ /usr/bin/check-bios-nx --verbose 

gives me:

"This CPU is family 6, model 15, and has NX capabilities but is unable to
use these protective features because the BIOS is configured to disable
the capability"

and:

$ grep ^flags /proc/cpuinfo | head -n1 | egrep --color=auto ' (pae|nx) '
gives me:
flags       : fpu vme de pse tsc msr *pae* .... 

The Security/CPUFeatures documentation here, states that, "the first flags line will include nx if the BIOS is not disabling the CPU feature, and the CPU is actually NX-capable"

To summarize so far, "nx" is not shown in the flags line from /proc/cpuinfo, whilst "pae", is... Is there any documentation available or is anyone able to recommend a procedure for installing the "-server or -generic-pae flavor of the 32bit kernel"... and/or how to make the necessary adjustments to the BIOS.

Many thanks for putting up with this rather unwieldy question!

share|improve this question
add comment

1 Answer 1

You can press F9 while booting to enter the ROM-Based Setup Utiltiy.

  • From System Options >> Processor Options choose "No-Execute Memory Protection".
  • If it is „Disabled”, set it to „Enabled”.

Excerpt from the manual:

No-Execute Memory Protection enables the hardware portion of a feature that protects systems against malicious code and viruses. When used in combination with an OS that supports this feature, certain memory is marked as not for executable code. Viruses that attempt to insert and execute code from non-executable memory locations are intercepted and an exception is raised.

Options include:

  • Enabled (default)
  • Disabled

NOTE: When using virtualization operating systems such as VMware ESX/ESXi and Windows Hyper-V, be sure to enable this option.

Information source:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.